[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

build depends on kernel-headers



In short, how do you do them?

AFAICT, I could conceivably add either

	Build-Depends: kernel-headers
or
	Build-Depends: kernel-headers-2.2.19

If I did the former, there doesn't seem to be any way to reliably
get at the kernel headers. The only way I can see is to hardcode
-I/usr/src/kernel-headers-2.2.19/include in the appropriate makefiles,
which is obviously not any good.

The latter'll obviously break as soon as 2.2.20 comes out and 2.2.19 gets
removed from the archive.

Also, doesn't there really need to be some way of saying "I need the
2.2 kernel headers" for programs that really do?

Help! :)

Cheers,
aj

-- 
Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. GPG signed mail preferred.

``_Any_ increase in interface difficulty, in exchange for a benefit you
  do not understand, cannot perceive, or don't care about, is too much.''
                      -- John S. Novak, III (The Humblest Man on the Net)

Attachment: pgpXn0e54jrUM.pgp
Description: PGP signature


Reply to: