[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#95801: won't let me upgrade perl from stable to unstable

reopen 95801

(note: skip to "rehash of problem" to see what this problem is all
about.  I am writing this to debian-devel, because I consider this a
serious problem which shouldn't be ignored).

>>>>> "Jason" == Jason Gunthorpe <jgg@debian.org> writes:

    Jason> On Mon, 30 Apr 2001, Brian May wrote:

    >> WARNING: The following essential packages will be removed This
    >> should NOT be done unless you know exactly what you are doing!
    >> perl-5.004-base (due to perl-base)

    Jason> I'm confused, why is this a bug? You asked it to remove a

No I didn't! I asked to upgrade to the latest perl from unstable!

    Jason> key component of perl, perl is an essential package, doing
    Jason> this may not actually complete, and it may break *inst/*rm
    Jason> scripts that need to be run, so it complains.

It is a bug. It means that I cannot upgrade from stable to unstable.

If you don't think it is a bug in apt, well fine, reassign it, but
please don't close it!!!!!

If you don't have time to read my report properly, ignore it, but
please don't close it!!!!

    >> The thing is, I can't even see how this is meant to work:
    >> dewey:~# dpkg --print-avail perl-base

    Jason> Try looking at the current version of perl-base, and then
    Jason> look at the thing that actually provides the pre-depends it
    Jason> needs, which in this case will be perl-5.004-base. This has
    Jason> very little to do with the packages you are going to
    Jason> install.

Did you even look at the output I quoted of perl-base? You seem to
contradict it, as it doesn't have any predepends, only a
conflicts. Perhaps you are confused? Please check the version number

(Or perhaps my mirror ftp.au.debian.org is badly out of date?)

If you do close this bug again without resolving it, then I guess you
have just demonstrated that Debian has grown too large and
bureaucratic, that we are no longer interested in getting upgrades
from stable to unstable to work anymore.

Otherwise, if you want to read some constructive suggestions for how
to improve the upgrade process in Debian from stable to unstable, read

= rehash on problem =

Trying to upgrade perl from unstable to unstable requires
perl-5.004-base be removed, which is marked as required. So you get
this serious looking error saying an essential package is going to be
removed. Please read the bug report for details.

(note: what is odd is on my first computer apt-get cleanly removed
perl-5.004-base without any complaints. Weird. Perhaps this
perl-5.004-base was only just recently removed from unstable, and
previously had Priority: <= required).

Package: perl-base
Essential: yes
Status: install ok installed
Priority: required
Section: base
Installed-Size: 10
Maintainer: Darren Stalder <torin@daft.com>
Version: 5.004.05-1.1
Pre-Depends: perl5-base
Description: Fake package assuring that one of the -base package is installed
 This package predepends on perl5-base that is provided by
 the various perl-...-base package. It's essential.

snoopy:unstable:~# dpkg --print-avail perl-5.004-base
Package `perl-5.004-base' is not available.

snoopy:unstable:~# dpkg --print-avail perl-base
Package: perl-base
Essential: yes
Priority: required
Section: base
Installed-Size: 2520
Maintainer: Brendan O'Dea <bod@debian.org>
Architecture: i386
Source: perl
Version: 5.6.0-21
Replaces: perl-5.005-base (<< 6), perl-5.6-base (<< 6), perl-modules (<< 5.6.0-19)
Provides: perl5-base, perlapi-5.005, perlapi-5.6.0, data-dumper
Depends: libc6 (>= 2.2.1-2)
Suggests: perl
Conflicts: perl-5.004-base, perl-5.005-base (<< 6), perl-5.6-base (<< 6), data-dumper
Filename: pool/main/p/perl/perl-base_5.6.0-21_i386.deb
Size: 839538
MD5sum: e60552c2c1dceda92c22b6273be953c3
Description: The Pathologically Eclectic Rubbish Lister.
 A scripting language with delusions of full language-hood, Perl is used
 in many system scripts and utilities.
 This is a stripped down Perl with only essential libraries.  To make
 full use of Perl, you'll want to install the `perl', `perl-modules' and
 optionally `perl-doc' packages which supplement this one.


All I want to do is upgrade from stable perl to unstable perl.

apt-get upgrade says that this is impossible without removing an essential

When I look at the latest version of Packages on my official Debian mirror,
it says that

1) perl-base is priority required.
2) perl-base conflicts with perl-5.004-base.
3) perl-5.004-base is priority required.
4) perl-5.004-base no longer exists in unstable.

I would assume that this means perl-5.004 is consider obsolete, and
this means some clean way is required to remove it without giving the
user the grave warnings. Hence my reason for submitting this to
apt. However, I agree this might not be the correct solution.

A better solution might be to keep the dummy package perl-5.004-base
(as that is all it seems to be), but to mark it as Priority: optional.
Then in two releases time we can get rid of it.
Brian May <bam@snoopy.apana.org.au>

Reply to: