[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Building Galeon -- Mozilla-based web browser with GNOME look and feel

On Fri, Mar 09, 2001 at 02:30:17AM +0100, Petr ?ech wrote:
> On Fri, Mar 09, 2001 at 12:21:40PM +1100 , Craig Sanders wrote:
> > On Wed, Mar 07, 2001 at 03:36:03PM -0800, Bradley Bell wrote:
> > > > Trying to keep up with galeon on a Debian system is an exercise in
> > > > frustration these days. Having to build your own mozilla (until the
> > > > last couple of days) is just the start. Does it really *have* to be
> > > > this hard?
> > >
> > > I had no problem making my own debs. what part are you having trouble
> > > with?
> > 
> > do you need to have the full mozilla source available to build galeon or
> > is the mozilla-dev package enough?
> I compile galeon CVS regulary. It doesn't work with CVS mozilla, but I had
> success with the unofficial mozilla 0.8. And you, mozilla-dev and
> libnspr4-dev (or what's it's name)
> > anyone got a copy of the debianised galeon sources? i only grabbed the
> just ./configure;make;make install

OK, folks: where can I find the autoconf macro AM_PATH_GNOME??

I installed the packages, mozilla-dev, libnspr4-dev, and everything
else listed in Build-deps of the source-deb found at

Then I pulled down the CVS sources, and tried building.  I couldn't
even generate the configure script.  The output is below.  
[I also had to install liboaf-dev and libgconf-dev, to get
some other macros defined.]


steve@riemann{galeon}sh autogen.sh 
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`autogen.sh' command line.

processing .
deletefiles is  macros/gnome-gettext.m4
Creating ./aclocal.m4 ...
Running gettextize...  Ignore non-fatal messages.
You should update your own `aclocal.m4' by adding the necessary
macro packages gettext.m4, lcmessage.m4 and progtest.m4 from
the directory `/aclocal'
Making ./aclocal.m4 writable ...
Running xml-i18n-toolize... Ignore non-fatal messages.
patching file po/Makefile.in.in
Hunk #2 succeeded at 34 (offset -2 lines).
Hunk #3 succeeded at 89 with fuzz 2 (offset -2 lines).
Hunk #4 succeeded at 216 (offset -1 lines).
Running aclocal  -I macros ...
aclocal: configure.in: 29: macro `AM_PATH_GNOME' not found in library

**Error**: aclocal failed. This may mean that you have not
installed all of the packages you need, or you may need to
set ACLOCAL_FLAGS to include "-I $prefix/share/aclocal"
for the prefix where you installed the packages whose
macros were not found

Where is the macro defined?  I installed all the *gnome*-dev packages
that looked reasonable, but still no dice.  What's the trick?

root@riemann{/root}dpkg --list '*gnome*dev'
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                 Version              Description
pn  gnome-db-dev         <none>               (no description available)
ii  libgdk-pixbuf-gnome- 0.10.0-1             The GNOME GdkPixBuf library - development files.
un  libglade-gnome-dev   <none>               (no description available)
ii  libglade-gnome0-dev  0.16-2               Development files for libglade (Gnome widgets support).
ii  libgnome-dev         1.2.12-2             The Gnome libraries -- development package
pn  libgnome-pilot-dev   <none>               (no description available)
pn  libgnome-pilot0-dev  <none>               (no description available)
ii  libgnome-vfs-dev     0.6.2-1              Libraries and include files for developing GNOME VFS app
ii  libgnomemm-dev       1.1.15-1             C++ wrapper for GNOME (development files)
ii  libgnomeprint-dev    0.25-2               The GNOME Print architecture (development files)
pn  libguilegnome-dev    <none>               (no description available)
pn  libobgnome-dev       <none>               (no description available)
pn  task-helix-gnome-dev <none>               (no description available)

Reply to: