[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#81397: [authorization] fails silently for normal users, cannot start server

On Sat, 6 Jan 2001, Steve Langasek wrote:

SL>On Sun, 7 Jan 2001, Eray Ozkural (exa) wrote:
SL>> Hamish Moffatt wrote:
SL>> > There IS a debconf question about it.. it's not like it just does it to you
SL>> > without asking. Maybe the debconf priority of the question is too low if
SL>> > too many people are missing it.
SL>> Do you think this is also what prevented display managers (xdm, gdm, wings
SL>> are the ones that I tries) to function correctly?
SL>Branden diagnosed this bug correctly.  A bug in the X server *cannot* cause
SL>xdm/gdm authentication to fail, unless perhaps Branden has started diverting
SL>files at random.  (I'll let you check this if you like.  Personally, I have
SL>greater confidence in his integrity as a developer.)  The display manager
SL>starts the X server, not the other way around, which means that the X server
SL>has no control over the display manager's behavior; and the authentication
SL>failure you reported came from the display manager and PAM, /not/ from the X
SL>Is it possible you missed a debconf question that controls authentication for
SL>display managers when you upgraded?  Yes, but it certainly wasn't in the X

It's in one of the xserver packages...-common, I think.

SL>Steve Langasek
SL>postmodern programmer

Pardon me, but you have obviously mistaken me for someone who gives a
email galt@inconnu.isu.edu

Reply to: