[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

useradd problem(!)


When I first installed Debian GNU/Linux on this machine, I reconfigured
it so that there is a "central" user-group called "users" which all
users of this system belong to.

I have now reconfigured it back to the default:


When running useradd, though, I get the following:

# useradd -m test
# ls -l /home
drwxr-sr-x   18 svn      users        1024 Jan  4 23:28 svn
drwxr-xr-x    2 test     users        1024 Jan  4 23:30 test

There. The new user 'test' still belongs to 'users' and doesn't get a
new group called 'test'.

I was curious, so I ran strace over adduser:

[first deleted 'test' again]

# strace useradd -m test
open("/etc/default/useradd", O_RDONLY)  = -1 ENOENT (No such file or directory)
access("/home/test", F_OK)              = -1 ENOENT (No such file or directory)
mkdir("/home/test", 0)                  = 0
chown("/home/test", 1001, 100)          = 0      <-- why GID 100?

(sorry for the long lines)

First, why is useradd looking for a file at /etc/default/useradd? Is
this an old location or what? I have only the following there:

total 8
-rw-r--r--    1 root     root           92 Aug 18 23:32 devpts
-rwxr--r--    1 root     root          641 Aug 18 23:33 rcS

Second, and this is my main problem, why is the GID 100? I have
explicitly configured "USERGROUPS=yes" in /etc/adduser.conf!

I run an up-to-date woody/testing here.

Help greatly appreciated,
Powered by Debian GNU/Linux

Reply to: