[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#80544: [rename] can't rename dir with valid permissions

Hi Martin,

cross-posting to debian-devel because your assessment of the
bug is totally wrong.

Martin Bialasinski wrote:
> Hi,
> > I can rename a directory to which I have permissions in shell
> > orion:mp3$ ls -ald Rob\ Zombie/
> > drwxrwxr-x    2 root     windows     16384 May 21  2000 Rob Zombie/
> These permissions are irrelevant.
> You want to change a directory item, therefore you need to have write
> permission on the directory containing this entry.
> Did you actually *try* to rename the directory on the shell, or did
> you conclude it should work from the above permissions?

Martin. Yes. I tried. Do you think I'm a newbie or something? Why 
do you think the file is owned by root? It's on windows partition...
And YES I've got group write rights. Why do you think I say that
I have permissions? Do you think everyone reporting a bug is a lamer?
Revise your prejudice please.

orion:exa$ groups
exa dialout cdrom audio dip video windows

I can do ANYTHING I WANT to those files okay?
only in gmc renaming (that is the old mv) will  fail

> > But gmc thinks I don't have sufficient rights and thus doesn't allow
> > me to graphically change the name from properties!! awesome bug.
> I assume, you don't run gmc as root, and your primary group is also
> not "windows".

insufficient assumptions. primary group? hah. I can either change
a file. Or not. Either I'm in a group or *not*.
There is no in between like a *primary group*. If an application
makes such a distinction, and does not allow renaming on the
basis of a vacuous distinction like this, we call it a BUG.
BTW, the same gmc happily moves files and dirs in the same directory.
The only thing it can't do is "renaming" which is AFAIK the same
thing as moving files. 

Check it out for yourself:

orion:Stuff$ ls -ald desktop.*
-rwxrwxr-x    1 root     windows       125 Nov 20  1998 desktop.ini
orion:Stuff$ mv desktop.ini desktop.what!
orion:Stuff$ ls -ald desktop.*
-rwxrwxr-x    1 root     windows       125 Nov 20  1998 desktop.what!
orion:Stuff$ mv desktop.what! desktop.ini
orion:Stuff$ ls -ald desktop.*
-rwxrwxr-x    1 root     windows       125 Nov 20  1998 desktop.ini

I am not making these up. It isn't fiction. I'm reporting a true
event. :(

I don't have to defend a bug like this. If you tried to actually
reproduce it before dismissing it like this, you would see what
an annoying bug it is. Do you prefer that the bug remains unreported?


I feel like a lot of bugs are being *censored*. :(

Eray (exa) Ozkural
Comp. Sci. Dept., Bilkent University, Ankara
e-mail: erayo@cs.bilkent.edu.tr
www: http://www.cs.bilkent.edu.tr/~erayo

Reply to: