[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


I'm having some problems getting a package finished because I can't figure
out conffiles... I tried posting to debian-mentors, but it seems to be
non-responsive, so I figured it was topical here as well.

For the package I'm building (VFTPD), I've got one key configuration file:

I've got a template that I install using the standard -f test, so it only
gets placed there if one doesn't exist. I also added /etc/ftppasswd to the
conffile line in debian/conffile

However, now I get this error whenever I try to test my source using
debian/rules binary:

dpkg-deb: building package `virtualftpd' in
dpkg-deb: conffile `/etc/ftppasswd' does not appear in package
dh_builddeb: command returned error code
make: *** [binary-arch] Error 1

So what am I doing wrong? I've tried looking in the wu-ftpd source package
to see if they did something differently, but apparently I'm missing what
I should be doing...


Warren Stramiello |
325909 GT Station | A good USENET Motto would be:
Atlanta, GA 30332 | a) "Together, a strong community"
 (404) 206-4208   | b) "Computers R Us."
------------------+ c) "I'm sick of programming. I think
WhiteRabbit       |     I'll just screw around for a while      |     on company time."
|   stramiello@WhiteRabbit.resnet.gatech.edu               |

Reply to: