[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ssh and hostname: solved by libc6-2.1.94-1??

My problems with ssh seems to be solved by the new version of glibc: libc6-2.1.94-1
Can somebody explain to my which changes in glibc fixed this??

1. Upgrade messages
apt-get dist-upgrade:

Setting up libc6 (2.1.94-1) ...
Name Service Switch has changed in the C Library.
Running programs may not be able to do NSS lookups until they are
restarted (for services such as ssh, this can affect your ability to login).
Note: restarting sshd should not affect any existing connections.

The services restarted (if present) are:
inetd, smail, sendmail, exim, ssh, netbase, apache, boa, nis, and proftpd.
If other services begin to fail mysteriously after this upgrade,
it may be necessary to restart them too.
Do you wish to Restart Services? [Y/n] 

Adiitional info:
order hosts,bind
search my.own.domain, localhost

2. Previous posting

I have problems with the latest ssh and the hostname for my debian
ssh from another computer in my local network works OK.
ssh from my box either to my own box or another does not work:

ssh -v localhost
SSH Version OpenSSH_2.2.0p1, protocol versions 1.5/2.0.
Compiled with SSL (0x0090581f).
debug: Reading configuration data /etc/ssh/ssh_config
debug: Applying options for localhost
debug: Seeding random number generator
hanging here
ssh -v works!!

same with ssh -v cl-dual vs ssh -v, the only
difference is that debug gives: srs@debian, not srs@cl-dual.
/etc/hostname is set to cl-dual.my.own.domain

/etc/hosts entries:       localhost               debian  cl-dual     cl-dual.my.own.domain   cl-dual debian

Q1) Where to change the hostname/domainname for things to work??
Q2) Where does the srs@debian entry in ssh come from, which function is called?
Q3) How to downgrade to the stable version ssh-v1 or finding the v2.1.x??

dpkg -l ssh:
ssh            2.2.0p1-1

Reply to: