[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Should emacspeak Pre-Depend on emacs?



On Sun, Sep 24, 2000 at 09:15:17PM -0400, James R. Van Zandt wrote:
> emacspeak requires emacs during installation, to compile its elisp
> code.  It already "Depends" on emacs.  Howver, since installing them
> at the same time fails, I believe I should change that to
> "Pre-Depends".  In accordance with section 2.3.4 of Policy, this has
> to be brought up for discussion on debian-devel first.

Gah.  With apt being the standard way to do things these days, this bit of
policy is a bit less important today than it used to be..  Perhaps we
should consider making it go away in the future?


> Are there any objections to my adding "Pre-Depends: emacs19|emacs20"
> to the emacspeak package?

If it's needed, it's needed...


> p.s. Does this mean that any package that compiles elisp code on
> installation should Pre-Depend on emacs?

Probably, yes.

-- 
Joseph Carter <knghtbrd@debian.org>               GnuPG key 1024D/DCF9DAB3
Debian GNU/Linux (http://www.debian.org/)         20F6 2261 F185 7A3E 79FC
The QuakeForge Project (http://quakeforge.net/)   44F9 8FF7 D7A3 DCF9 DAB3

Due to the closed source development model of XFree it is impossible
to support, or even speculate about, features in pre- or beta releases
of XFree.
        -- Marcus Sundberg



Reply to: