[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrading from 1.3: big kudos!


btw, I am sending a copy to debian-devel, since I would like
to congratulate with all the community

I have a Debian 1.3 system in my office

I decided today to upgrade to potato; I got the upgrade directory,
I am following the instruction in the README-upgrade,
and trying to use the apt-get method;
so here is what I do

I mounted a remote NFS archive with debian potato in it

I installed   dpkg -i apt_0.1.10_i386-libc5.deb
and           dpkg -i dpkg_1.4.0.8.deb

I set /etc/apt/source.list

I ran  apt-get update

I ran apt-get dist-upgrade

Unfortunately, when it comes to installing the libc6,
the post-inst says 

/var/lib/dpkg/info/libc6.postinst: cd: /etc/rcS.d: No such file or directory

so I do     mkdir /etc/rcS.d 
and I do       dpkg -i apt_0.1.10_i386-libc5.deb
(since the new apt has been installed,
  and it doesnt work without  libstdc++2.10)
and I do    apt-get -f install

this time libc6 installs ok, but apt stops , asking for an 'apt-get update'
(probably, its databases have gone haywire in the process)

I run  apt-get update

I run apt-get dist-upgrade

I have to adjust /etc/modules
and ran update-modules

I do  cd /var/log
        mv wtmp wtmp.libc5
        touch wtmp
        cd /var/run
        cp /dev/null utmp
I reboot, it works !

so, I would suggest that you put, in README-upgrade,
an advisory, so that people will do    mkdir /etc/rcS.d
as a first thing before upgrading to potato

thanks and big kudos to all Debian: it is quite uncommon
that an operating system may upgrade like this
(consider also that it passed from a libc5 to a libc6 arch...
and it took just 45 minutes)

now I am going to install some new version of packages
(like a new kernel and new openssh)


ps: I have posted a bug to libc6: libc6 should create
 /etc/rcS.d in postinst (if it doesnt exist)

Andrea C. Mennucci,   Scuola Normale Superiore, Pisa, Italy

Reply to: