[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ~133 upcoming RC bugs?



Previously Josip Rodin wrote:
> However, earlier versions, such as the one in slink, will still fail! That's
> the reason why any packages using two or more packages in C:+R: fields must
> declare either a Pre-Depends: dpkg (>= 1.6.8) or Conflicts: dpkg (<< 1.6.8).

A Pre-Depends or Conflicts won't work, since the running dpkg might still
be the old version. The best way to do it would be to add a --assert
option and make packages use both that and a Pre-Depend (so apt will try
and update dpkg first anyway).

Wichert.

-- 
  _________________________________________________________________
 / Generally uninteresting signature - ignore at your convenience  \
| wichert@liacs.nl                    http://www.liacs.nl/~wichert/ |
| 1024D/2FA3BC2D 576E 100B 518D 2F16 36B0  2805 3CB8 9250 2FA3 BC2D |

Attachment: pgpIexdx4Bq2M.pgp
Description: PGP signature


Reply to: