[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gdm MIT-COOKIE problem

I have been trying to get gdm to work again, as it broke a little while
ago.  I thought it was gdm, but I found an old .deb (which worked at the
time for me, 1.0.0-5) but it didn't fix the problem.

(I'm using unstable, and gdm 1.0.0-9).
Symptoms, gdm starts up X, and then hangs there. :0.log says that xlib is
denying access, the MIT-COOKIE isn't valid.  I think the message even
implies that it is malformed (I'll send the log entry from home, later).

Recompiling does *not* help.

It seems to be a problem with the fact that (according to the change log
in xlib) the new stricter MIT-COOKIE checking in xlib keeps gdm from
checking in.

I've tried all kinds of things, but nothing works.  The most spectacular
failure is when I log in as root and do an 'xauth merge
/var/state/gdm/authdir/:0.auth'.  That causes the X server to die and

Can someone point me at something to explain what is going on so I can fix
this?  I'm not an official developer, just someone who wants it to work!


"Boarding this vessel is an act of war. Ergo we surrender."
		--Rimmer (Red Dwarf episode: Gunmen of the Apocalypse)
The Doctor What: <fill in the blank>             http://docwhat.gerf.org/
docwhat@gerf.org                    (finger docwhat@gerf.org for PGP key)

Reply to: