[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#42244: tetex-bin xlib6g dependency

severity 42244 wishlist

Marcus Brinkmann writes:
 > On Sun, Aug 01, 1999 at 02:21:00PM +0200, J.H.M. Dassen Ray" wrote:
 > > On Sat, Jul 31, 1999 at 17:38:45 +0200, Gerhard Poul wrote:
 > > > I just want to tell you that I consider it a bug that tetex-bin depends on
 > > > xlib6g.
 > > 
 > > It isn't a bug. Read the Debian policy manual, in particular "5.8. Programs
 > > for the X Window System".
 > Hu? There is nothing in the policy that forbids splitting out the parts that
 > need X.
 > _If_ parts of the tetx package would need to be recompiled, once with X
 > support and once without, you would be right, as policy says (in 5.7, btw)
 >      Do not create two versions (one with X support and one without) of
 >      your package.
 > This is _not_ the case here. We simply need two packages, one which does
 > contain the parts of tetex-bin that do not require X and one small package
 > which requires the parts that require X.
 > There wouldn't be two versions of the package. The content would be
 > different.

So, that should be a wishlist bug. I changed that. 

I will consider building yet another package from tetex, but I don't
really like the idea of splitting tetex again. Perhaps we should
discuss this issue a bit more. If enogh people give me connvincing
points here, ...


Reply to: