[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New Versioned Perl packages soon

Le Thu, Jul 01, 1999 at 01:00:02AM -0700, Darren/Torin/Who Ever... écrivait:
> If you are building Perl packages, you'll need to build them with Perl
> 5.005 using the policy defined in /usr/doc/perl-5.\d+-doc/perl-policy*
> You'll need to download perl-5.005 and use dpkg --force-conflicts to
> install it if you still have older non-versioned packages installed.

That's particulary true for the maintainer of binary perl modules. They'll
have to install perl-5.005 for compiling the module.

Those who know that their packages are 100% pure perl modules do not need
to install perl-5.005 but will still need to update their package to
follow the new perl policy (so that non-binary modules are installed 
in /usr/lib/perl5 and so that the dependency is changed to perl5 instead
of perl).

You can note that if you follow the guidelines of the perl policy, you can
make /usr/bin/perl point to /usr/bin/perl-5.004 (so that perl-5.004 will
still be used until the transition is completed) and use this line to
build your module package :
$ PERL=perl-5.005 debuild -e PERL

FYI, the latest perl policy is currently in the perl-5.00X-doc package and on
the web here : http://pandora.debian.org/~hertzog/

If somebody cannot (rapidly) update their perl packages, they can ask
on debian-perl for someone else to do it (via an NMU).

> If you're just build packages with some scripts in it, just depend on
> perl5 rather than on perl.  All the perl-5.\d+ packages provide this for 
> you.

And note that you cannot use a versionned depends on perl5 since it's a
virtual package.

Hertzog Raphaël >> 0C4CABF1 >> http://prope.insa-lyon.fr/~rhertzog/

Reply to: