[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: using cvs-buildpackage with debian only packages?

> How do I set up cvs-buildpackage to work with debian only packages (no
> upstream source file)?

What is the version number of the package, as defined by the first
line of debian/changelog?  It should be of the form 1.3.1 for a Debian
native package, so that the CVS tag will be debian_version_1_3_1.

If you want a version number like 1.3-1 for a Debian-only package, you
will probably find that you have problems, as cvs-buildpackage uses
the presence of '-' in the version number to determine whether or not
it is a Debian native package.

Moral: don't use '-' in a native Debian package if you are using



  Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
             Debian GNU/Linux Developer.  jdg@debian.org
       -*- Finger jdg@master.debian.org for my PGP public key. -*-

Reply to: