[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jdk1.1_1.1.7v1a-2 error

On Fri, Apr 09, 1999 at 09:49:08AM +0200, Petr Cech wrote:
> On Thu, Apr 08, 1999 at 01:58:27PM -0500 , Chris McClimans wrote:
> > when I install jdk1.1_1.1.7v1a-2 on a recent potatoe system I get:
> recent means glibc2.1? (libc6 >= 2.1), then this is known problem.
> > 
> > Warning: can't find /usr/lib/jdk1.1/bin/../bin/checkVersions, hope that's ok
> > /usr/lib/jdk1.1/bin/../bin/i686/green_threads/jre: error in loading shared
> > libraries: /usr/lib/jdk1.1/bin/../lib/i686/green_threads/libjava.so: undefined
> > symbol: _dl_symbol_value
> > There was a discussion about this a while back, did we find the problem?
> IMHO preload glibc 2.0 library 

I tried this, but it is not sufficient. jdk contains wrapper scripts, so you
try to load #!/bin/sh with glibc 2.0 preloaded, which doesn't quite work if
you have glibc2.1 bash :) 

Then, I had to edit the wrapper scripts somewhat, and that worked partly.
After some time messing with, I gave up and installed hamm on a spare
partition for the stuff I needed to do.


`Rhubarb is no Egyptian god.' Debian http://www.debian.org   finger brinkmd@ 
Marcus Brinkmann              GNU    http://www.gnu.org     master.debian.org
Marcus.Brinkmann@ruhr-uni-bochum.de                        for public  PGP Key
http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       PGP Key ID 36E7CD09

Reply to: