RFC: renaming fvwm-common
At present, the fvwm-common is created by the fvwm package and
contains the following:
xpmroot - a utility to display an XPM pixmap in the root window
BuildXLockMenu - a utility to produce a list of possible xlock modes
for use in an FVWM 2.x menu
quantize_pixmaps - reduce collective colormap of collection of XPMs
setup-background - a utility to set the color or place a pixmap in the
and lots and lots of icons/pixmaps.
I figure that BuildXLockMenu can be done away with by running the
program once an leaving the results in the fvwm package -- it hardly
seems worth polluting the program space with such an unnecessary
package. But then we are left with no fvwm-dependent stuff at all, so
that the package name "fvwm-common" becomes misleading, to say the
Here's the question: if I choose to rename the package, which would
seem like a sensible thing to do, what would be a sensible name to
Or should there even be *two* packages: one for small utilities such a
xpmroot, maybe called something like wm-utils, and the other for
icons, called something like xicons.
I'd really appreciate feedback before I make these changes.
Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
Debian GNU/Linux Developer. firstname.lastname@example.org
-*- Finger email@example.com for my PGP public key. -*-