[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New imlib packages -- please test

On Sun, 7 Feb 1999, Ossama Othman wrote:

> If anyone has time, could you please test the packages to make sure that
> they are okay.  I need to do a new-maintainer upload and I didn't want to
> break anything.
Thats a very sane idea for such an important package.
Sorry that I have to tell you that it doesn't work for me as well as
the old package.  I did the following test:

  1. Compiled my program (paul image viewer) with the old packages (1.9.2.-1)
  2. Loaded some image files of different format (PNG, TIFF, JPG, PCX)
  3. Installed your packages (1.9.2-2). Remark:  I've installed the
     1.1.13 GTK+ packages, but your ImLib packages require 1.1.14.
     I really don't expect any connection between this conflict regarding
     to the bug I'll describe now, because I know the source code of
     the loading routines and they don't depend from the GTK+ (gdk) code!
  4. Tried to load the files mentioned above, but failed sometimes(!) :-(.
  5. Relinked the program to be sure, but failed anyway.

> Note that I didn't do any major changes from how I got them from Brian so
> they should work.  All I basically did was update the Standards-Version
> and make the packages lintian clean (libtool, menu, etc.)
I noticed the splitting of the imlib loading functions into several
dynamically loadable libs, which was the intention of RasterMan as I
know from a private mail.  Im not sure if this is the reason, but it
is the only visible change for me, which could cause the failure.
To be sure I tested the simple example from the ImLib-HTML-tutorial
for the plain ImLib (without "gdk").  This worked well with your package.
Because it was confusing for me, I tried the example which I ship with
my libgtkimreg-dev_0.0.7-1.deb package, which contains the loading
code from the ImLib-HTML-tutorial for GDK-ImLib.  This fails again.
So it seems to fail only for gdk-imlib.  I've certain reasons not to
upgrade to GTK+1.1.14 at this actual moment, so I can't check whether
the reason is my conflicting GTK+ package.  You could possibly check
your libraries by installing my libgtkimreg packages (available in
the potato tree) which install a very simple example in /usr/doc.
Please inform me if it works well in loading the sample image shipped
with it.  If yes I'll have to do further investigations at my site.

Thanks you for supporting Debian with this important package anyway


Reply to: