[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unidentified subject!

I may have old versions of a lot of packages (most come from hamm),
however, this behaviour of fakeroot has me very puzzled, and I wondered
what is going on??? Is this something to do with buggy signal
handling putting the foreground zsh process into the background??

| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name            Version        Description
ii  fakeroot        0.0-14.2       Gives a fake root environment.

[ I log in ]
Last login: Mon Feb  1 18:47:24 on tty3.
No mail.
Mon Feb  1 18:48:14 EST 1999

[I run fakeroot]
[501] [snoopy:bam] ~ >fakeroot zsh
[501] [snoopy:root] ~ >echo ok
[everything is ok until I cancel a command with ^C]
[502] [snoopy:root] ~ >echo ok
[501] [snoopy:bam] ~ >

[The computer automatically skipped the above prompt and went back to
the root prompt, so I pushed enter several times]
[502] [snoopy:root] ~ >
[501] [snoopy:bam] ~ >
[502] [snoopy:root] ~ >

[ I tried typing in id several times, I didn't make any mistakes]
[501] [snoopy:bam] ~ >id
zsh: command not found: d
[502] [snoopy:bam] ~ iid
zsh: command not found: d
[502] [snoopy:bam] ~ >id

[The program crashed so I pushed ^C]
[503] [snoopy:root] ~ >
[Here I pushed ^D and logged out of the shell... Hang on, if fakeroot
was running, shouldn't I have exited only that instead???]

I have lots of zsh processes still running, so I guess I will have
to manually kill them.

I am going to install the fakeroot from the frozen libtricks package,
as I suspect it will help.

Brian May <bam@snoopy.apana.org.au>

Reply to: