[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mod-perl, Apache, and Unresolved Symbols...

	Trying to get mod-perl running under apache, but I am having a
problem or two. I grabbed the libapache-mod-perl deb package out of
unstable and installed it on my nearly stock hamm machine. First off it
complained about needing apache-common (>=1.3.3), but only an older of
version of this package exists from what I could find after much
searching. Installed that one, and then forced mod-perl to install.
	Next, once I have apache configured to load the mod-perl module,
on startup of apache, I get a failure, and an error that the symbol
'ap_log_rerror' of mod_perl.so can not be resolved. I can't find the
library that has this symbol in it after a decent bit of searching.
	I am aware that I might be mixing apples and oranges by grabbing
pieces from hamm and unstable and installing them on the same machine. I
tried installing a newer version of apache, but that only caused more
unresolved errors on mod_rewrite.o, for symbol lstat. Tried upgrade libc6
(where lstat should be found) to the unstable version, but no luck.
	What am I missing here? Or better yet, what version of what do I
need installed to get mod_perl to work? Thanks!

|   "For to me to live is Christ, and to die is gain."                     |
|                                            --- Philippians 1:21 (KJV)    |
|  Ryan Kirkpatrick  |  Boulder, Colorado  | rkirkpat@nag.cs.colorado.edu  |
|               http://www-ugrad.cs.colorado.edu/~rkirkpat/                |

Reply to: