[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug25882, upgrade from non-Debian has gid conflict

This sounds like a policy decision.  Either we 

  a) add a script to detect old passwords, if this is possible since
     the user probably just copied the password file,
  b) write a script for taking an old password file and coercing the
     filesystem into the proper id space.  BTW, I have done this by
     hand and it isn't too bad.  I simply added 1000 to the old IDs.
  c) we document this with a warning for now and revisit it with one
     of the above solutions.

I'd say go for the last since this has been sitting since the middle
of August.

Reply to: