[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Q] Problems installing OSS on a slink machine running on 2.1.127

[Sending to debian-devel because this might a developer issue]


I have a licensed copy of OSS.  I was happily running it with kernel
2.0.35  I recently upgraded to kernel 2.1.127.  I downloaded the version
of OSS (http://www.opensound.com/) for 2.1.127 and am having problems
while installing.  Here are the various things I tried -

I. Downloaded kernel 2.1.127 from http://www.kernel.org/.  Compiled a
custom kernel with make-kpkg.  Installed kernel and rebooted.

II. Downloaded OSS (osslinux391a-2035.tar.gz) for Linux 2.1.127 (UP). 

III. Extraced the binaries and started running ./oss-install.  Chose to
install under /usr/local/lib/oss

IV. Install fails while trying to recompile sndshield with the following
message -
*** 'sndshield' version error ***
You should get new version of the sndshield module
See /usr/local/lib/oss/Readme for more info.

V. /usr/local/lib/oss/Readme says -

The kernel image shipped with many Debian releases differs from the
kernels. For this reason OSS will need the sndshield module to be
in your system. Unfortunately this may fail because the directory
of Debian differes from all other Linux distributions. See notes about
"Solving "sndshield" version incompatibilities" later in this document
more details.


Solving "sndshield" version incompatibilities
sndshield is a kernel version dependent module which hides minor changes
between Linux kernel versions. It's even possible that some patches or
(rare) kernel config changes break compatibility even the kernel version
number doesn't change. For example the standard OSS/Linux package is not
compatible with kernels configure for SMP (for this reason we distribute
a special SMP version of OSS/Linux for the latest "production" kernel).
So messages about kernel 2.0.30 being incompatible with OSS compiled
are not impossible.

OSS uses a special sndshield module to isolate most kernel version
functions from other driver modules. Sources of sndshield are
with OSS/Linux so it would be possible to fix the compatibility by
this module. Precompiled sndshield modules for various systems are
OSS and the installation program picks the suitable one (provided that

When OSS/Linux is installed it verifies compatibility between kernel and
the driver by trying to load all driver modules. If any of the modules
to load it attempts to recompile sndshield. However compiling sndshield
succeed only if some criterias are met:

1) The kernel sources should be installed on the system. Preferably in
2) The kernel should have been configured with support for modules
and module versioning (Set version information on all symbols for
3) The kernel include file directories should be symbolic links pointing
to the
active kernel sources in /usr/src/linux. This is not set up correctly by
default in Debian Linux systems.

As the last resort you can install the "official" kernel sources from
ftp.kernel.org and recompile the kernel. After that just try to install

VI. After reading the above I made a kernel-source package for 2.1.127
and installed it.

VII. cd /usr/src; ln -s kernel-source-2.1.127 linux

VIII. I still keep getting the same problem trying to install once

IX. I tried the following one at a time -

cd /usr/include; mv linux linux.bak; ln -s /usr/src/linux/include linux

cd /usr/include; mv linux linux.bak; ln -s
/usr/src/linux/include/asm-i386 linux

cd /usr/include; mv linux linux.bak; ln -s /usr/src/linux linux

and tried installing with each (making sure I reverted back to the old
/usr/include/linux each time after things failed).  Same problem once

[And finally to the question]

How can I make sndshield compile OK?  My machine is a HP Kayak XU which
has a AD 1816 sound card.

"You know, Itchy and Scratchy Land isn't for kids. They have a place
 called 'Parents' Island'. Yeah! Dancing, bowling, fashionable shops,
  over one hundred bars and saloons, and a world-class chemical
               dependency center." -- Lisa Simpson
Sudhakar C13n   http://people.netscape.com/thaths/   Indentured Slave

Reply to: