[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libraries in slink should not depend on libstdc++2.8, but libstdc++2.9

libstdc++2.8 and libstdc++2.9 are binary incompatible. The current g++
compiler in slink (2.91.xx) cannot produce binaries which are
compatible to binaries produced with g++ 2.90.xx. That's not a problem
for binaries that depend on libstdc++2.8, but it could be a problem
for libraries that depend on libstdc++2.8. I suggest to recompile all
libraries in slink that depend on libstdc++2.8 to eliminate this
problem. I could only find one library that depends on libstdc++2.8
(libfltk0), but there could be libraries in other packages as well...

Reply to: