[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

HELP!! binaries not executed (fwd)

This email explains the problems I had with
my deleted root partition

George Kapetanios
Churchill College
Cambridge, CB3 0DS    E-Mail: GK205@cus.cam.ac.uk
U.K.                  WWW: http://garfield.chu.cam.ac.uk/~gk205/work_info.html

---------- Forwarded message ----------
Date: Thu, 8 Oct 1998 14:04:46 +0100 (BST)
From: "G. Kapetanios" <gk205@cus.cam.ac.uk>
To: Chris <chris@ormond.unimelb.edu.au>
Subject: Re: HELP!! binaries not executed (fwd)

On Thu, 8 Oct 1998, Chris wrote:

> On Thu, Oct 08, 1998 at 01:12:30PM +0100, G. Kapetanios wrote:
> > 
> > > What kernel are you running?
> > it is debian 1.0 kernel 2.0.0 (the only disks that would work)
> > 
> > > What shell are you using (and from what dist)?
> > the initial shell of debian i think ash and then bash from debian 1.0
> > > Have you run e2fsck on the partition?
> > 
> > yes no errors reported
> > i was thinking it may help if i check the hidden characteristics of the
> > files in /usr.
> > As i remember (i am at work now ) if i copy the file to / it still does
> > not work if i copy a file from / to /usr it works 
> > 
> > > 
> > > BTW, I've had no problems with current boot dists, is that the only thing
> > > stopping you reinstalling the entire system?
> > yes i tried the final bo disks but the disks were not reliable and i cant 
> > find them on the net any more. i tried the hamm july 21 1998 
> > both from floppies and hard disk
> > there seems to a problem in base2_0 for my system. error goes by too 
> > quickly to see i think it has something to do with a file not found 
> > could be connected to the other problem, i guess.
> > thanks very much for your help 
> > hope you can give me some advice. 
> > george 
> Sorry for the delay, was on the phone to the gf (geez she can talk!)
> Now, from my guess I'd say that the kernel you are using does not support
> ELF binaries (I haven't verified this, it's just a guess - I'll check
> later).  I think this especially as you can copy a file into usr and
> still execute it, which means a problem with the file type (The only other
> possiblity is if the binaries in /usr/ are ALL corrupted - very unlikely.
> If you want to check this send me a binary (say less) with your next mail).
> I would suggest updating the kernel.  Now, there are two ways of going...
> you can try to update the system by install 2.0, which means we'll have to
> deal with the error mentioned above, or you can try to install a new kernel.
> To install a new kernel, try downloading a precompiled kernel, putting this
> on your root partition, and pointing lilo to it (I assume you know how to
> do that?  If not let me know).  I think you can get a debian package
> containing a precompiled kernel (but it's a new package format, you'd have
> to extract the image from it) or I can send you one if you like.  An even
> better solution is to use another machine to compile one.  Id say to use 
> kernel 2.0.3x (although it doesn't really matter).
> Otherwise we can try and fix that error, in which case you'll need to tell
> me *exactly* what steps you went through during your attempted install.
> (ie.  where got the files from, what installation media your using, where
> you put the base2_0.tgz file, what options you use in the installation tool,
> etc, etc).

Thanks very much for your help.
Now I would rather go for the debian 2.0 installation so that I can avoid
the problematic libc5-libc6 upgrade. The story is as follows 
Two days ago I had installed the bo disks ok. But I made a stupid (yet
another ) mistake I had the system installed on /dev/hda4 which should be
/usr and not on /dev/hda3 which is normally my / 
Then i had a lilo.con pointing to /dev/hda3 and therefore I could boot
from the floppy but not from the disk. I tried installing the hamm disks
from the second hard disk.  (I have the debian hamm disks and distribution
in /dev/hdc2 and /dev/hdc3  The critical stuff I do not want to lose re in
/dev/hdc1 All these partitions seem ok I don't want to access them too
often in case something goes wrong.)
The installation broke down at the base2_0.tgz stage with an error
similar to that I have now (but not the saem I think) This was probably
becasue of the / /usr mixup 
 When i
realised the e / /usr mixup I decided to reinstall from scratch
rather than copy the
because i thought the t the system.map e.t.c. would have to chnage 
 But the bo disks would not work now (disks corrupted) (very unluckI could
download them because I can't find them on the net.
Then I installed the debian 1.1 stuff. with 2.0.0 kernel. 
Now I don't think i have tried the hard disk install method for the 2.0.0
I downloaded yestrday the hamm disks from a mirror and tried it. 
Rescue is ok  the problem comes with the install base system. 
The disks are read stored and unpaked the program starts running but stops
pretty soon and saya it can't find something 

I do't know what because the ncurses prompt is on top. 
I press ok it saya something too fast for me to read and goes back to the  
main menu 
I was thiing of downloading the base2_0.tgz stuff putting them in the
/dev/hda1 (dos) partiton and rerunning the install in case 
it minds that the stuff is in /dev/hdc2
I really appreciate your help

> Anyway, hope this helps,
> Chris
> -- 
> ----------------------------------------------------------------------
> REALITY.SYS corrupted: Reboot universe? (Y/N/Q)   ....Debian GNU/Linux
> ----------------------------------------------------------------------
> Reply with subject 'request key' for PGP public key.  KeyID 0xA9E087D5

George Kapetanios
Churchill College
Cambridge, CB3 0DS    E-Mail: GK205@cus.cam.ac.uk
U.K.                  WWW: http://garfield.chu.cam.ac.uk/~gk205/work_info.html

Reply to: