[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Package maintainer script policy.

Rob Browning <rlb@cs.utexas.edu> wrote:
> I thought people were supposed to be able to skip versions entirely.
> Say going from bo->slink.  If so, then this wouldn't have helped at
> all.

Well, autoup.sh certainly won't let you do that, though I suppose
apt would.

And in that sense you're right: it would be nice to arrange so that a
person could upgrade straight from bo (or rex) to slink without having
to install hamm.

And, given this as a goal, maybe it still makes sense to introduce a
libreadline2-compat package (which supplies what's currently provided
by libreadline2) and an empty libreadline2 which predepends on the
compat package.


To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: