[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Overlaps between bo and hamm

Oliver wrote:
>The trouble is, bible-kjv-text and bible-kjv (>> 4.00-4) together make
>up what was bible-kjv (<< 4.00-5); so I cannot use Replaces because I
>would force dpkg to remove an essential part of the package pair. It seems
>to me that Conflicts does the job properly.

"Replaces" does not cause a package to be removed unless all its
files are subsumed by another package.  If bible-kjv-text says
"Replaces: bible-kjv (<< 4.00-5)" with no conflicts, it would just
cause dpkg to remove the necessary files from the installed version
of bible-kjv when it installed bible-kjv-text.

Charles Briscoe-Smith
White pages entry, with PGP key: <URL:http://alethea.ukc.ac.uk/wp?95cpb4>
PGP public keyprint: 74 68 AB 2E 1C 60 22 94  B8 21 2D 01 DE 66 13 E2

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: