[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug: #15573: perl should predepend on perl-base


Santiago Vila Doncel, in an immanent manifestation of deity, wrote:
>On 4 Dec 1997, Darren/Torin/Who Ever... wrote:
>> Hmm.  A thought as I spell-checked this.  Can you pre-depend and depend
>> on the same package?  perl's control will now look like:
>> ...
>> Pre-Depends: perl-base (>=5.004.04-2)
>> Depends: perl-base (=${Source-Version})
>> ...
>This way, dpkg will refuse to install perl until perl-base >= 5.004.04-2
>is installed and configured, but since the only perl-base
>version compatible with perl is exactly ${Source-Version}, it will have
>to install and configure that version, perl-base ${Source-Version}.
>Pre-Depends: perl-base (=${Source-Version})
>not have the same effect?

Not if I'm interpreting the dependencies correctly.

In your version, every time perl is upgraded, perl-base (for that
version) must be installed and configured before we can upgrade perl.  I
think that takes two separate invocations of dselect.  (warning: I don't
use dselect)

With my version, you only have to have perl-base installed and
configured if there is a danger of Perl not being there, i.e. before 5.004.04-2.
Any other time (5.004.04-3+), perl-base just needs to be installed, not
necessarily configured.  This way folks have to exit and re-enter
dselect fewer times.

- -- 
<torin@daft.com> <http://www.daft.com/~torin> <torin@debian.org> <torin@io.com>
Darren Stalder/2608 Second Ave, @282/Seattle, WA 98121-1212/USA/+1-800-921-4996
@ Sysadmin, webweaver, postmaster for hire.  C/Perl/CGI programmer and tutor. @
@		     Make a little hot-tub in your soul.		      @

Version: 2.6.3
Charset: noconv
Comment: Processed by Mailcrypt 3.4, an Emacs/PGP interface


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: