[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: e2fsprogs_1.10-7 available for testing

I grabbed the 1.10-7 sources, and built them, and tried running them
on this filesystem:
/dev/hdd2            2763953 2006501   700290     74%   /z3

and it actually worked (unlike -6, and unlike -7 when I didn't fix

% sudo csh -fc '( setenv LD_LIBRARY_PATH $cwd/debian/tmp/lib/ ;   $cwd/build-i386/e2fsck/e2fsck -n /dev/hdd2 )'
e2fsck 1.10, 24-Apr-97 for EXT2 FS 0.5b, 95/08/09
Warning!  /dev/hdd2 is mounted.
/dev/hdd2 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/hdd2: 116902/714752 files (0.8% non-contiguous), 2100732/2858184 blocks

I was hoping we could cheat and add a test case to the build, like this:

% touch /tmp/fstest
% mke2fs /tmp/fstest 4000000
(answer y)

e2fsprogs -2 and -6 both fail here, but so does my build of -7, with
fstest at about 32M blocks, and

Writing inode tables:  128/ 489
Warning: could not write 8 blocks in inode table starting at 1048596: Attempt to write block from filesystem resulted in short write
(repeated with increasing values for a while...)

I was hoping that we could use this as a cheap sanity test (relying on
sparse files and all) but the mke2fs didn't work -- perhaps there's
another bug lurking?  Or does it work fine on devices, and I'm just
getting caught cheating? :-)

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . Trouble? 
e-mail to templin@bucknell.edu .

Reply to: