[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#9417: xxgdb: Segmentation violation



meskes@topsystem.de writes:

> Package: xxgdb
> Version: 1.12-9
> 
> Trying to debug the following program with xxgdb I get a 'Segmentation
> violation' before it really comes up:
> 
> #include <unistd.h>
> #include <stdio.h>
> 
> main()
> {
>     char *cwd;
>     
>     printf("Starting program!\n");
>     if ((cwd = getcwd(NULL, 64)) == NULL) {
>     	printf("Got an error!\n");
> 	perror("pwd");
> 	exit(-1);
>     }
>     (void) printf("%s\n", cwd);
>     return (0);
> }
> 
> Michael
> 
> -- System Information
> Debian Release: 1.3
> Kernel Version: Linux gauss 2.0.30 #9 Fri Apr 11 13:42:13 CEST 1997 i686 unknown
> 
> Versions of the packages xxgdb depends on:
> gdb	Version: 4.16-7
> xlib6	Version: 3.2-3 (Provides Virtual Package elf-x11r6lib)
> libc5	Version: 5.4.23-3
> xlib6	Version: 3.2-3

I can't reproduce this behaviour, please can someone confirm that
there is a problem. Please check the program  and run xxgdb on it.
I'm running 
gdb   Version: 4.16-6 (which is the current version for bo)
xlib6 Version: 3.2-3 
libc5 Version: 5.4.23-2
I'll try to get above evrsions and see whether there is a problem, but
I really can't see where it should come from. Do you set something in
your .gdbinit file? I really want to get this done before bo is
released.
        Helmut

-- 
Helmut Geyer                                Helmut.Geyer@iwr.uni-heidelberg.de
public PGP key available :           finger geyer@saturn.iwr.uni-heidelberg.de

Attachment: pgp2o38dmI0gH.pgp
Description: PGP signature


Reply to: