[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

1997-04-04 install disks vs. kernel-image

> People should test the 1997-04-04 disks. They will be moved to frozen
> and unstable soon.

My girlfriend just installed her NEC laptop with the 1997-04-04
disks.  (She's a mach kernel hacker, so most of the difficulty was
believing that the install wouldn't just trash the whole machine :-)

Mostly uneventful.  The one major problem:  we did a normal install,
then copied over pcmcia* and installed them, and were then able to
bring up a pcmcia ethernet card and dselect access=nfs.  That worked
fine... until we rebooted!  Turns out that while the resc1440 kernel
and the pcmcia package are consistent, the kernel-image-2.0.29 kernel
is *broken* with respect to getksyms... I've reported this before, and
I don't know if 2.0.30 is done right (it probably is) but that's not
relevant -- the 1.3 kernel *must* be correct.  It's just a matter of
rebuilding that package...  In the meantime, if she reboots with the
resc1440 disk I think she'll be able to use the pcmcia support, then
can go on from there to load kernel packages that I built.

Minor bits: the broadcast address calculation was "right" but I had to
override it by hand (I use a /26 netmask ending in .128, so it decided
that 191 was correct for all-ones -- but some of my machines are old
sunos systems, so we use .255 even if it's "wrong(tm)" and there
wasn't an obvious way to override it.

Also, her eyes glazed over during the initial dselect-based
install... oh, and the tex installation defaults are still a bit odd
(it had tetex-bin and -base marked 'purge' but tetex-dev marked
'install'... possibly because mfdcfnt was marked 'install' and they
conflicted? dunno really.) 

Also, the newfs step hung on 42/52 inodes written... the first time.
The second time, we skipped the (successful first time) badblocks
scan, and it did fine.

When it got to the "last" step, "make disk bootable" I think, it
listed alternates of "make boot floppy" and "reboot system" but "next"
just went back to "make disk bootable".  A little confusing.

Oh, and the initial dselect "access" setting gave a "broken pipe"
message and a bit of shell (ending in head? or tail?) while setting
the path to the "stable" dir, but worked anyway, and didn't complain
while setting the contrib and non-free entries.

All in all, it went pretty smoothly!  Good job all...

Reply to: