[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation report: 1997-04-04

I'm not one of the formal beta testers :-), so forgive me if I deviate from
the expected form.

I did an install from CD-writable on a high-end though slightly
mis-configured Micron system at Pixar: Pentium Pro in a Dual Pentium
Pro motherboard with one CPU socket unpopulated, 32M RAM (I told him to
get more), Diamond Stealth 3D 2000 display card, 4GB IDE disk on the
first IDE, IDE CD on the second IDE, PS/2 mouse on PS/2 auxillary port,
U.S. keyboard.

One-floppy install worked great! No problems finding the files on the CD.

The cfdisk can't seek bug still exists on this disk set. Fdisk worked.

I ended up going to a shell in the second window to add partitions
using fdisk. After that, the installation menu program didn't detect
the new partitions and I had to drop into cfdisk to force it to
re-detect them. It should really scan partitions before an operation
that uses partitions, whether it thinks it knows about them or not.

The "configure the base system" and "configure the network" steps can
be run before the base system has been extracted. They should test for
the existance of /target/sbin/init or another base file, and refuse to
run if it isn't there, complaining that the base system has not been
extracted. Several other steps need this test as well, it should
probably replace (and include) require_root() for these steps.

Graphical X configuration of the xserver-s3v did not work the first
time. I saw one shared library complaint that went away when I ran
"ldconfig", and I noticed that xserver-s3v was configured before
xserver-vga16. I'm sorry I don't have a better report on this.
Hopefully I'll catch it on my next install.

Once I got graphical X configuration working, conguring the mouse
was a problem. The screen stopped reading the keyboard and the cursor
was jumping around at the top of the screen. I had to go through it
4 times before I got it right. GPM had successfully configured the mouse
before this, the X configuration picked up that it was a /dev/psaux mouse,
but did not pick up that it used the PS/2 protocol.

I hate MIME priority selection. We need a global tool for this.

"dunc" won't configure a "don't dial" or "no login dialogue" connection.
This is useful for directly-connected systems and serving to palmtops like
the Newton.

Tetex refused to install, giving a page-long spiel about how to remove
old Tex packages, but this was a fresh install.

Overall, it's a great release. I think I would have had problems installing
it if I wasn't an expert. None of this is impossible to fix.


Bruce Perens K6BP   Bruce@Pixar.com   510-215-3502
Finger bruce@master.Debian.org for PGP public key.
PGP fingerprint = 88 6A 15 D0 65 D4 A3 A6  1F 89 6A 76 95 24 87 B3 

Reply to: