[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg can't handle multiple replaces (was: Freezing Bo)

> To get around the dependency problem with tetex, couldn't you just
> check to see if the offending packages are installed in the
> preinst script? If any of them are installed, print a helpful
> message and exit.

I was thinking the same thing.  The netscape package does just this.
If it detects an older version, it exits with an error and a message
saying to "dpkg --purge netscape" and try again.
                                 ( bcwhite@verisim.com )
    In theory, theory and practice are the same.  In practice, they're not.

Reply to: