[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

smail doesn't like trailing dot


I run a small, private mailing list here using the address
"list@ods.com" (that's not the real name but that doesn't matter).
The list is actually run on my personal system so I can maintain it
myself.  This is done by aliasing "list@ods.com" on ods.com to
"list@elo.sw.ods.com".  This worked fine until recently.  

For reasons that I still don't understand, our sysadmin has decided to
change some our aliases to include a trailing dot in the host name.
In the case of my list, the alias on ods.com is now
"list@elo.sw.ods.com.".  This has broken the list as smail doesn't
like the trailing dot when the host name is the local host.  This
is shown by the following test:

elo$ /usr/sbin/smail -bv list@elo.sw.ods.com.
list@elo.sw.ods.com. ... not deliverable: router inet_hosts: MX record for elo.sw.ods.com points to local host

Smail seem to be able to handle the trailing dot when the host reolves
to another host.  FWIW, the sendmail provided with Solaris 2.5.1
handles the local host problem more gracefully, albeit strangely.  It
send the mail on to the configured mail host, which the promptly send
it right back without the trailing dot.

Does anyone know if this is a bug in smail?  I'd need to know before
I raise any more of a stink with our sysadmin.  I've worked around
the problem for now by adding both dotted and undotted versions to
the hostnames field in /ect/smail/config.

David Engel                        ODS Networks
david@sw.ods.com                   1001 E. Arapaho Road
(972) 234-6400                     Richardson, TX  75081

Reply to: