[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libgdbm1 dependency problems

I am very slowly starting to ramp on how to use debmake.  In looking
at the latest libgdbm1 packages as examples, I found some dependency
problems.  I haven't looked far enough yet to know if they are caused
by debmake or just Cristoph's packaging, but I thought I'd let you all
know about them.

>From 'dpkg --info libgdbm1_1.7.3-15_i386.deb': Package: libgdbm1
 Package: libgdbm1
 Version: 1.7.3-15
 Architecture: i386
 Provides: elf-libgdbm
 Installed-Size: 27
 Maintainer: Christoph Lameter <clameter@debian.org>
 Source: libgdbm

There should probably be a dependency on libc5 here.  The reason is
that libgdbm1 is useless without it.  I realize that any packages
containing binaries actually using libgdbm1 will also depend on libc5,
potentially making this dependency unnecessary, but it doesn't hurt to
be explicit here.

>From 'dpkg --info libgdbm1-dev_1.7.3-15_i386.deb':
 Package: libgdbm1-dev
 Version: 1.7.3-15
 Architecture: i386
 Depends: libgdbm1
 Installed-Size: 84
 Maintainer: Christoph Lameter <clameter@debian.org>
 Source: libgdbm

libgdbm1-dev should definitely depend on libc5-dev in addition to
libgdbm1.  Without this dependency, a user could install incompatible
development packages (eg. libgdbm1-dev and libc6-dev).

David Engel                        Optical Data Systems, Inc.
david@ods.com                      1001 E. Arapaho Road
(972) 234-6400                     Richardson, TX  75081

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: