[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Weird problems with dpkg and libc 5.4.7



Warwick HARVEY <warwick@cs.mu.oz.au> writes:

> # dpkg -i /home/debian/development/binary-i386/base/debianutils_1.3.deb 
> (Reading database ... 7354 files and directories currently installed.)
> Unpacking debianutils (from .../base/debianutils_1.3.deb) ...
> dpkg: failed to open package info file `/var/lib/dpkg/updates/3dq' for
> reading: No such file or directory
> 
> Please upgrade to a newer version of dpkg
> 
> dpkg: error processing
> /home/debian/development/binary-i386/base/debianutils_1.3.deb (--install):
>  subprocess pre-installation script returned error exit status 1
> Errors were encountered while processing:
>  /home/debian/development/binary-i386/base/debianutils_1.3.deb
> # 
> 
> I can't find any "Please upgrade ..." message in the source though...  ??

The debianutils.preinst script is generating that message:

dpkg --assert-support-predepends ||
  ( echo -e "\nPlease upgrade to a newer version of dpkg\n"; exit 1 )

Try to run "dpkg --assert-support-predepends" by itself and see if it
craps out, and what the return code is.  Also try in the following
order:

1. reinstall dpkg.

2. run some dpkg command that fails with -D7777 to turn on all the
debugging flags and look at the ouput.

3. run an strace on dpkg to see what's going on.

And you say it works fine under libc5.2?  You should probably do steps
2 and 3 with 5.2 and compare the ouput.  That'll hopefully produce the
answer.

> Hmm, with this recent discussion of processor-dependent optimisations, I
> perhaps feel I should mention that all this is on a clunky old 386DX/33...

Oh sorry, we don't support 386's any more.  Forget everything I said,
and go buy a P6.


Guy

--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com


Reply to: