[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#5338: e2fsprogs 1.06 pre-depends on itself

Package: e2fsprogs
Version: 1.06-2


I've made rather a nasty mistake when converting e2fsprogs to the new
source format.

Since the package has always included the shared libraries used by the
e2fsprogs utils, which don't appear to be used by any other package, I
chose to ignore the policy manual, and keep the package together.

dpkg-shlibs then put the package itself into it's own predepends, since it
depends on libraries which are included in the package!  Now dselect
can't cope with installing this package.

I'm going to fix this by spliting e2fsprogs into _3_ packages, which I
propose go into the following sections:

e2fsprogs-lib  base required       -  shared library files.
e2fsprogs-bin  base required essential  - the utils themselves
e2fsprogs-devel  devel optional    - header files and static libraries.



Michael Nonweiler <mrn20@debian.org>
Trinity College, Cambridge, England.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: