[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#4741: Removing emacs fails if there are files in /usr/local/lib/emacs

  Richard> Package: emacs 
  Richard> Version: 19.34-2
  Richard> attempting to 'dpkg -r emacs' fails if any files have been placed
  Richard> in /usr/local/lib/emacs or /usr/local/lib/emacs/site-lisp. (At
  Richard> least with dpkg 1.4.0 it does)
  Richard> What good is creating an empty directory tree in /usr/local if it
  Richard> complains if I stick anything in there?

Come on, this is nothing to do with emacs, but with dpkg.  Did you ever
install a kernel-source package and tried to remove it after you built a
kernel? Same result as all the .depend still hang around which are not in
dpkg's list.

I know you don't like the emacs package to create empty dirs in your
/usr/local, but we already discussed this and concluded that emacs and perl
are allowed to put empty dirs there.

Dirk Eddelb"uttel                             http://qed.econ.queensu.ca/~edd

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: