[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#4135: dpkg-source must attent to VERSION_CONTROL

package: dpkg
version: 1.3.4

Some of us use the VERSION_CONTROL environment variable to get emacs
and patch (among others) to create a revision history when editing

Unfortunately, dpkg-source doesn't pay any attention to the setting
for that variable, and therefore assumes patch will work in a specific
fashion when that is not guaranteed.

It must either make sure that VERSION_CONTROL isn't set before running
patch (which is probably the most reliable solution), or try and
figure out exactly which files are the correct ones to delete based on
intimate knowledge of how the VERSION_CONTROL variable influences the
behavior of programs.

"Don't let me make you unhappy by failing to be contrary enough...."

Reply to: