[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#2654: libc5 predependancy on ld.so1.7.14-2

	When I install libc5-5.2.18-2.deb I get the following errors
[root@aneurysm:/home/mdl]# dpkg --install libc5-5.2.18-2.deb
dpkg: regarding libc5-5.2.18-2.deb containing libc5, pre-dependency problem:
 libc5 pre-depends on ldso (>=1.7.14-2)
  ldso is installed, but is version 1.7.14-2.
dpkg: error processing libc5-5.2.18-2.deb (--install):
 pre-dependency problem - not installing libc5
Errors were encountered while processing:

	It requires ld.so 1.7.14-2 or greater, but version *is* 1.7.14-2!! It
should work..

	When I installed ld.so 1.7.14-2 I got this message.

[root@aneurysm:/home/mdl]# dpkg --install ld.so-1.7.14-2.deb
(Reading database ... 7603 files and directories currently installed.)
Preparing to replace ldso (using ld.so-1.7.14-2.deb) ...
Unpacking replacement ldso ...
dpkg: error processing ld.so-1.7.14-2.deb (--install):
 trying to overwrite `/usr/include/dlfcn.h', which is also in package libc
Expect some cache has wrong version warnings if upgrading
to version 1.7.x for the first time.
mv: `ld.so.1.7.10' and `ld.so' are the same file
mv: `ld-linux.so.1.7.10' and `ld-linux.so.1' are the same file
Errors were encountered while processing:

please mail a solution to mdl@garion.it.com.au

Thanks in advance.


Reply to: