Re: Uploaded: bind-4.9.3-P1-2
> Rob Leslie writes ("Re: Uploaded: bind-4.9.3-P1-2"):
> > > Carl V. Streeter writes ("Re: Uploaded: bind-4.9.3-P1-2"):
> > > > Rob Leslie writes:
> > > > > * Now conflicts with older kernel images.
> > > >
> > > > CONFLICTS: netstd (<<2.00), image (<<1.3.56)
> > >
> > > Please, do NOT use Conflicts like this. It really messes up the kind
> > > of smooth installation I'm trying to get dselect to be able to do.
> > Um, please do not use Conficts like how?
> You're using it as a kind of reversed dependency, right, to try to get
> people to upgrade their netstd and/or image first ?
> You douln't do this unless the packages actually do conflict, which
> basically means sharing files.
I see. It does in fact conflict with files in netstd prior to version 2.00.
To satisfy the kernel, however, would it be acceptable to test the kernel
version (via uname) from preinst and raise an error if it's not new enough?
I don't like the idea of depending on `image' when so many people build their