[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#2018: dpkg version numbers & dpkg-split

Package: dpkg
Version: 1.0.8

I tried the new dpkg but version number and dpkg-split aren't correct.
Transcript below.

~/new# dpkg --status dpkg
Package: dpkg
Essential: yes
Status: install ok installed
Priority: required
Section: base
Maintainer: Ian Jackson <iwj10@cus.cam.ac.uk>
Version: 1.0.8
Description: Package maintenance system for Debian GNU/Linux
 This package contains the programs which handles the installation and
 removal of packages on your system.
 The primary interface for the dpkg suite is the `dselect' program;
 a more low-level and less user-friendly interface is available in
 the form of the `dpkg' command.

~/new# dpkg-split --version
Debian GNU/Linux `dpkg-split' package archive split/join tool version
1.0.7.  Copyright (C) 1994,1995 Ian Jackson.  This is free
software; see the GNU General Public Licence version 2 or later for copying
conditions.  There is NO warranty.  See dpkg-split --licence for details.

~/new# dpkg-split -S 100 -s dpkg-1.0.8.deb
Splitting package dpkg into 2 parts: 1 2 done

~/new# rm dpkg-1.0.8.deb

~/new# dpkg-split -j dpkg- dpkg-
dpkg-split: file `dpkg-' is not an archive part: Unknown error
~/new# dpkg-split --info dpkg-
file `dpkg-' is not an archive part
~/new# dpkg-split --info dpkg-
file `dpkg-' is not an archive part
Erick Branderhorst@heel.fgg.eur.nl +31-10-4635142
Department of General Surgery (Intensive Care) University Hospital Rotterdam NL

Reply to: