[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: git, and X11

On Wed, 26 Jul 1995, Ian Murdock wrote:

> Can the git package be moved out of Incoming, or will this still cause
> problems with the creation of the Packages file?
> -rw-rw-r--  1 imurdock  debian  117826 Jul 25 18:23 git-4.3.7-1.deb
> -rw-rw-r--  1 imurdock  debian      20 Jul 25 18:23 git-4.3.7-1.diff.gz
> -rw-rw-r--  1 imurdock  debian  299953 Jul 25 18:23 git-4.3.7-1.tar.gz

I didn't see a response to this.  As I recall, I was going to make
a change to eliminate the '^' chars from git's extended description,
but didn't do this after seeing someone (Ian J?) post that he'd
change the script which constructed the Packages file.  Do I
need to do anything?

On to X11.  I tried another X11 install.  Following is a log
of comments as I did it.  I subsequently found the config file
which specifies /dev/ttyS0 for the mouse and tried adding a
"Baud 1200" line to it (though comments in the file indicated
that "baud" was only needed fotome Logitech mice.  No joy.


I'm attempting an X11 installation on 0.93R6
This installation has never had X11 installed.
I've never been thru a successful X11 installation
under debian (I did get it more-or-less running
a couple of times using Heluut's stuff, but I
wouldn't call it successful, and that was over
a 0.93R5 debian base.)

I'm doing this in "dumb user" mode (not difficult for me).

Reading the ANNOUNCE file, I don't see a concise
set of instructions on how to proceed with a new
x11 installation.

It talks about xbase, so I'll install that, using
another VC.

It ran mkfontdir.
It asked if I wanted to create an XFree86 configuration
file.  I'll say 'y'.

It says I need to know some info, and says to press
enter to continue or control-c to abort.  I'll press

it doesn't abort.  It goes on and asks config questions
which a user might not be able to answer at this point.
I'll answer the questions.

  What mouse?  #2, Mouse Systems.
  Do I want ClearDTR and ClearRTS?  Dunno.  Say 'y'.
  Emulate3Buttons?  Say 'n'.
  Mouse device?  /dev/ttyS0.
  Non-ASCII?  Say 'y'.
  Sync details, and another offer of control-c to abort.
  Press ^C.  Ah.  It aborted.

Try dpkg --install xbase.deb again.
This time it said it was replacing xbase.
It ran mkfontdir.
XFree86 configuration running to agiain.  <enter> this time.
  What mouse?  #2, Mouse Systems.
  Do I want ClearDTR and ClearRTS?  Dunno.  Say 'y'.
  Emulate3Buttons?  Say 'n'.
  Mouse device?  /dev/ttyS0.
  Non-ASCII?  Say 'y'.
  Sync details, enter them. (30-60, 50-90)
  Monitor ID strings.
  Card 21 (Cirrus GD542x)
  Screen type 5 (Default: XFREE86_SVGA)
  Make symlink?  'y'.
  Video Ram?  (3: 1024K)
  Board ID strings
  No clockchip setting.
  Probe for clocks (no)
  modes 432
  Hmmmm cycles back to bpp question.  Select 4 (OK)
  write /etc/X11/XF86Config? 'y'.
  Set up system to start xdm at boot time?  'n'.
  You may now start the Xwindow system.

I know those prompts came from a program which doesn't know I'm
not ready to start X11, so I won't try.  A more naive user might
try "startx" or "xdm" at this point.

Back to the ANNOUNCE file.  install xsvga.deb.  Install xfont*.deb.
Hmmmm. it says I need xfaseR6 and xr5shrlib too.  Install them.

"startx".  X11 comes up OK.  Mouse doesn't work.
Ctrl-Alt-Backspace.  (a more naive user won't know about this).

Mouse did work under previous X11 installs.  Setup details forgotten.
run kermit, set line /dev/ttyS0.  move mouse, press buttons.
I see activity at 1200 and 2400 baud.
The 1200 baud activity looks reasonable (distinct and distinguishable
activity per-button)

Reply to: