[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1163: diplogin, routing

I would like to describe one problem I'm having:

I am running  Debian GNU/Linux 0.93  Release 5  on a 486DX2 8M/500M with an
Ethernet card connected to
6 PC's (running WFWG TPC/IP) and to a 286 router (running ROUTESS)
connecting me to the central Internet service in Iceland (INTIS) and
everything works just great :-)

The Debian is used as a host for the 6 local PC's and is also (of cource)
accessible remotely from all known Internetproviders, Home & abroad. We run
a nameserver, httpd, ftpd, telnetd, sendmail, ..... and all is fine.

-----------------Now to my problem.--------------

I have been using  dip(login) version 3.3.7m (uri) as a SLIP server, but I
can only access the Debian Server, not even the other 6 PC's on the same
network.  At home I run WFWG/Trumped. By configuring my Web-brouwser to use
the Debian host as a proxy server, I can reach websites all around the globe
but Telnet, Ftp, Mail, Irc is impossible to other hosts than my Debian. I
can't even ping the other computers on the network.
I have tried to use route, arp, hosts, ..... read all available documents,
and now I'm calling for help!

This message is sent from my SLIP connection at home. From the Office I can
also reach home, but the connection
is only possible between those two computers: Debian Host & my home machine.

***************** I will list some hopefully usefull information: **************

Kernel routing table
Destination     Gateway         Genmask         Flags MSS    Window Use Iface
localhost       *      UH    1936   0    63650 lo
mozart.siberia. *      UH    232    0      934 sl0
localnet        *        U     1436   0    59526 eth0
default         isnet-gw.siberi *               UG    1436   0   241621 eth0

lo        Link encap:Local Loopback
          inet addr:  Bcast:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0
          TX packets:51415 errors:9 dropped:0 overruns:0

eth0      Link encap:10Mbps Ethernet  HWaddr 00:20:AF:55:4D:AB
          inet addr:  Bcast:  Mask:
          RX packets:252915 errors:0 dropped:0 overruns:0
          TX packets:307189 errors:0 dropped:0 overruns:0
          Interrupt:3 Base address:0x210

sl0       Link encap:Serial Line IP
          inet addr:  P-t-P:  Mask:
          UP POINTOPOINT RUNNING  MTU:296  Metric:1
          RX packets:83043 errors:0 dropped:0 overruns:0
          TX packets:84136 errors:0 dropped:0 overruns:0

gko:: A:SLIP,296
# End of diphosts

4) NAMD.BOOT                            (****should be irrelevant)
directory       /etc/domain
cache           .                       root.cache
primary         0.0.127.in-addr.arpa    named.local
; This is your forward (name -> address) map
;               domain                  file containing data
primary         siberia.is              siberia.is.soa
; This is your reverse (address -> name) map
; If you have more networks, you must service those also
;               domain                  file containing data
primary         140.4.193.in-addr.arpa  140.4.193.in-addr.arpa.soa

******************* END OF LISTS *************************

Thats all for now.

With prethanks, G.K.Ottarsson

Reply to: