[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted postgresql-common 183 (source) into unstable



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 05 Jul 2017 16:15:48 +0200
Source: postgresql-common
Binary: postgresql-common postgresql-client-common postgresql-server-dev-all postgresql postgresql-client postgresql-doc postgresql-contrib postgresql-all
Architecture: source
Version: 183
Distribution: unstable
Urgency: medium
Maintainer: Debian PostgreSQL Maintainers <pkg-postgresql-public@lists.alioth.debian.org>
Changed-By: Christoph Berg <christoph.berg@credativ.de>
Description:
 postgresql - object-relational SQL database (supported version)
 postgresql-all - metapackage depending on all PostgreSQL server packages
 postgresql-client - front-end programs for PostgreSQL (supported version)
 postgresql-client-common - manager for multiple PostgreSQL client versions
 postgresql-common - PostgreSQL database-cluster manager
 postgresql-contrib - additional facilities for PostgreSQL (supported version)
 postgresql-doc - documentation for the PostgreSQL database management system
 postgresql-server-dev-all - extension build tool for multiple PostgreSQL versions
Closes: 777623 809811 830789 834264 851874 853868 862420 866729
Changes:
 postgresql-common (183) unstable; urgency=medium
 .
   * Team upload.
 .
   [ Nishanth Aravamudan ]
   * debian/supported-versions: add Ubuntu 17.10. (Closes: #862420)
 .
   [ Bernd Helmle ]
   * postgresql-common.spec: Fix installation path of manpages.
 .
   [ Alex Badics ]
   * pg_ctlcluster: Use pg_ctl.conf during stop too.
 .
   [ Christoph Berg ]
   * PgCommon.pm: Sort get_versions and get_version_clusters output.
   * PgCommon.pm: Revert to old quote_conf_value behavior, the new regexp was
     too liberal. The new input behavior is retained, though.
   * pg_ctlcluster: Error out if a recovery.conf file is found in
     /etc/postgresql to catch a common mistake. (Closes: #853868)
   * pg_upgradecluster: Allow configuring the maintenance database.
     (Closes: #851874)
   * pg_upgradecluster: Pass config directory to pg_upgrade instead of
     symlinking the config files. This breaks using "-m upgrade" for upgrades
     *to* versions before 9.2; upgrades from older versions are unaffected.
   * pg_upgradecluster, pg_renamecluster: Use default pg_ctl timeout when
     stopping cluster.
   * pg_dropcluster: Remove custom xlog directory. (Closes: #830789)
   * pg_createcluster, pg_ctlcluster: cd / to prevent warnings from PostgreSQL
     tools. (Closes: #834264)
   * pg_wrapper: Don't fail if no local cluster exists on port 5432.
     Code cleanup. (Closes: #777623)
   * pg_lsclusters: --start-conf shows start.conf information.
   * createcluster.conf: Add add_include_dir='conf.d' for drop-in PostgreSQL
     config snippets in /etc/postgresql/version/cluster/conf.d/ and
     include_dir='/etc/postgresql-common/createcluster.d' for pg_createcluster
     config snippets.
   * t/051_inconsistent_encoding_upgrade.t: Remove, only relevant for <= 8.2.
   * logrotate config: Ship as static conffile again and remove ucf handling.
   * pg_conftool: Fix operation when no cluster exists yet.
   * pg_conftool: --boolean normalizes boolean variable in output; use this in
     debian/maintscripts-functions.
   * debian/maintscripts-functions: Unconditionally call invoke-rc.d, and drop
     path names from program invocations (Standards-Version 4.0.0).
   * debian/maintscripts-functions: Use 'invoke-rc.d "postgresql@$ver-*" stop'
     to prevent upgrading/removing server packages from stopping other major
     version clusters when running systemd. (Closes: #809811)
   * debian/maintscripts-functions: Avoid update-alternatives failing if the
     user removed /usr/share/man. (Closes: #866729)
   * t/TestLib.pm: Vacuum tests left behind when postmaster and pg_autovacuum
     were removed. Update test counts in *.t.
   * B-D on debhelper (>= 10.1) | dh-systemd (>= 1.19) to pick up
     dh_systemd_start.
Checksums-Sha1:
 c90ab1d92634240265192a1420e077f66fef216b 2339 postgresql-common_183.dsc
 386c723f782f30b7ab23869f06a45fa645654c96 204196 postgresql-common_183.tar.xz
 d430902fb3a3e21a839ad3cc3bf9423d8f8b7169 5818 postgresql-common_183_source.buildinfo
Checksums-Sha256:
 71aea6d7b80c5ba2448986372bdd721cbd72eeb1142dce5db6560c7beb608a45 2339 postgresql-common_183.dsc
 9efa619a96f605fd415863c0cb8b9f79aa0592f025620aec1847c0351ab72150 204196 postgresql-common_183.tar.xz
 9e777361cb6e3459a72e8a6dc3ff8c27c6837fed7d7664f81b2ce400a85dea3c 5818 postgresql-common_183_source.buildinfo
Files:
 e80e8a7bf9935156497844281a1b07a5 2339 database optional postgresql-common_183.dsc
 9ad1c16660cdedc221ce42bdd3182b7e 204196 database optional postgresql-common_183.tar.xz
 3b58b43a3b9bcd2ec937657f7e221e9f 5818 database optional postgresql-common_183_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEXEj+YVf0kXlZcIfGTFprqxLSp64FAlldK2EACgkQTFprqxLS
p64iGBAAtyYNb0m5wCNKqELHvGZHAQkDLm9GSjnKCt8PQbi72LvKaMwLi2tvQE32
iux4zX3OaJyjZGK+jobFKsZn8GRUQ/LriQpJcwRXcYC8+WipiiwjSDHvHl6C8l2M
6KnW0EFIp7BGh0+wtgFtBEHQ7qeSxnZ0BaE5WlhAczeZSG9++0uTdRsthVkgeQFg
reeQP9jQ46iguajOrumlp1dK9u3Be3wR8NvIp0DeyegkKRh8LRqUT14Jz71hk27M
zSso1MCJ0719cvhMPQ7dQ7cfD7cdOya7at+EWD2w54bAwmC0OQ+B0c2LimuZ1CDd
QNQD70n0GBuQ2AOmmJvop3dSUOt9eNIZt6B+I0Zda3j7UXWN1El0WfA5WAjq7oFH
sA03yLBAG0DytP2oyOScUd9mREGw+oLNhTcGcrzcT0UsuhSc+GsK3E+50EWeK+Ln
uUWwlW1ZCGi9IWM2uBe+Swz9mFFldUeZwHBApG8ZmCUOuO7hNGK7D983ziofO5jt
gSFFpDUryc7SpuLsKKxRYVq1J7ozdUE+AX+JPtyvYk9cq+j47Y0CKutapl8pCRls
xrvj47xMeezjgWNY0Q+BQi5Z8eNE5WctU9jjq7hQ2vSjOqPxkvKLWLLyGIVLgMKW
BWm0gFP12Mwb3wB8qenjeiUP1Y5JHqWsD7p8S/bXMkk0yll0dRU=
=4D01
-----END PGP SIGNATURE-----


Reply to: