[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted postgresql-common 107 (source all)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 03 May 2010 17:40:09 +0200
Source: postgresql-common
Binary: postgresql-common postgresql-client-common
Architecture: source all
Version: 107
Distribution: unstable
Urgency: low
Maintainer: Martin Pitt <mpitt@debian.org>
Changed-By: Martin Pitt <mpitt@debian.org>
Description: 
 postgresql-client-common - manager for multiple PostgreSQL client versions
 postgresql-common - PostgreSQL database-cluster manager
Closes: 579768
Changes: 
 postgresql-common (107) unstable; urgency=low
 .
   [ Peter Eisentraut ]
   * Add initial support for 9.0 (pre-release snapshots for now):
     - cleanpg: Remove 9.0 clusters.
     - pg_createcluster: Clone configure_8_4() as configure_9_0().
     - pg_upgradecluster: Migrate obsolete/changed configuration parameters.
   * pg_wrapper: Fix spelling.
   * In maintainer scripts, instead of "#!/bin/sh -e" use a separate "set -e",
     per lintian.
   * debian/control: Bump Standards-Version to 3.8.4; no changes necessary.
 .
   [ Martin Pitt ]
   * cleanpg: Do not remove the /var/log/postgresql/ directory itself, only its
     contents, to avoid logcheck falling over.
   * t/020_create_sql_remove.t: Do not consider $PG_GRANDPARENT_PID an unsafe
     environment, it's set by 9.0 servers.
   * t/060_obsolete_confparams.t: Add a full configuration for 8.4, so that
     upgrades to 9.0 can be tested.
   * t/052_upgrade_encodings.t: Specify 'C' locale when creating the ASCII
     encoded test database for versions >= 8.4, otherwise we have a
     locale/encoding mismatch.
   * t/TestLib.pm: Abort tests on FAILURE=shell and the shell exits with
     nonzero. This avoids endless followup error shells once it's clear that
     the following ones are doomed anyway.
   * PgCommon.pm: Add new function get_db_locales() which reads lc_ctype and
     lc_locales for a particular database. This replaces the
     get_cluster_locales() function for >= 8.4 server versions (which moved
     from global to per-database locales).
   * pg_upgradecluster: Use get_db_locales() instead of get_cluster_locales()
     for upgrades from >= 8.4.
   * pg_ctlcluster: Drop check for valid locales. We can only determine them
     (using pg_controldata through get_cluster_locales()) for <= 8.3 clusters,
     which are obsolete in sid/lenny. For >= 8.4 clusters, we need to start the
     server to find out the locales, at which point the check is pointless.
   * pg_upgradecluster: Run pg_restore with --disable-triggers when running in
     --data-only mode. (Closes: #579768)
   * t/020_create_sql_remove.t: We now assume that /var/log/postgresql/ always
     exists, and is writable by the "postgres" user. Thus if we delete the log,
     running "pg_ctlcluster start" should be able to recreate it. This fixes
     the 020_create_sql_remove.t test failure in "umask 077" mode, and uncovers
     some more inconsistencies wrt. log directory permissions.
   * pg_createcluster, testsuite: Fix permissions of /var/log/postgresql/ if
     this script creates it.
Checksums-Sha1: 
 22317e206f153424803a868baa9d48b9ec85b1a7 903 postgresql-common_107.dsc
 94da2449f4c43ead81873845279782ad4b834eb2 120683 postgresql-common_107.tar.gz
 36037bb3260a45d0fe49bc46f9e917b653ad0411 122404 postgresql-common_107_all.deb
 ffcc3e47630bcf03bbf47c9f23f955e4a12c621e 52946 postgresql-client-common_107_all.deb
Checksums-Sha256: 
 67a3c2e1cb3ffa501093e7692453500fd516eb508df4e34d82ea58e502a35160 903 postgresql-common_107.dsc
 c2e1f401cc57a8c9f45c733289080c158fc271846c976f11694daacb6367345d 120683 postgresql-common_107.tar.gz
 9ad846545ac53c07a91fa992697fef14b03362174bec09544977ee1be39a0e65 122404 postgresql-common_107_all.deb
 98fc0148fbeae82f9ff338cf90913d2d9affa9dd0870f5c64ea98964241407ba 52946 postgresql-client-common_107_all.deb
Files: 
 ff0ddf0525d10d171adac123edc9dac1 903 database optional postgresql-common_107.dsc
 c36a848999bd05130c477239bb176063 120683 database optional postgresql-common_107.tar.gz
 e29ac7e95680a62d34e7cab5817cfbf7 122404 database optional postgresql-common_107_all.deb
 619b3048304a5c8a30614358c94ce45e 52946 database optional postgresql-client-common_107_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkve74oACgkQDecnbV4Fd/LNpwCeOnCWr6nzTYqAK56w9RSyhlGT
MEgAn216IVSjKZ9i9wcGTcj9/bBPiCh8
=QIIA
-----END PGP SIGNATURE-----


Accepted:
postgresql-client-common_107_all.deb
  to main/p/postgresql-common/postgresql-client-common_107_all.deb
postgresql-common_107.dsc
  to main/p/postgresql-common/postgresql-common_107.dsc
postgresql-common_107.tar.gz
  to main/p/postgresql-common/postgresql-common_107.tar.gz
postgresql-common_107_all.deb
  to main/p/postgresql-common/postgresql-common_107_all.deb


Reply to: