[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted shadow 1:4.1.1-1 (source i386)

Hash: SHA1

Format: 1.7
Date: Thu, 03 Apr 2008 01:31:10 +0200
Source: shadow
Binary: passwd login
Architecture: source i386
Version: 1:4.1.1-1
Distribution: unstable
Urgency: low
Maintainer: Shadow package maintainers <pkg-shadow-devel@lists.alioth.debian.org>
Changed-By: Nicolas FRANCOIS (Nekral) <nicolas.francois@centraliens.net>
 login      - system login tools
 passwd     - change and administer password and group data
Closes: 445484 461374 461670 467236 467488 470745 471802 471935 472244 472506 472575 472951 473279 473555 473646
 shadow (1:4.1.1-1) unstable; urgency=low
   * New upstream release. This closes the following bugs:
     - Fix errors when gpasswd is called without a gshadow file.
       Closes: #467236, #467488
     - Fix newgrp segfault when the primary group is not listed in /etc/groups.
       Closes: #461670
     - Fix infinite loop in usermod when two groups have the same name.
       Closes: #470745
     - Make SE Linux tests more strict, when the real UID is 0 SE Linux checks
       will be performed. Closes: #472575
     - Option --password added to groupadd / groupmod (like useradd / usermod).
       Closes: #445484
     - Remove patches applied upstream:
       + debian/patches/451_login_PATH
       + debian/patches/462_warn_to_edit_shadow
       + debian/patches/467_useradd_-r_LSB
       + debian/patches/466_fflush-prompt
       + debian/patches/480_getopt_args_reorder
       + debian/patches/496_login_init_session
       + debian/patches/408_passwd_check_arguments
       + debian/patches/412_lastlog_-u_numerical_range
       + debian/patches/407_adduser_disable_PUG_with-n
     - Updated patches:
       + debian/patches/504_undef_USE_PAM.nolibpam
         $(LIBCRYPT) $(LIBSKEY) $(LIBMD) are no more included in libshadow.la.
         Avoid link to unneeded libraries (spotted by dpkg-shlibdeps).
       + debian/patches/501_commonio_group_shadow
       + debian/patches/429_login_FAILLOG_ENAB
       + debian/patches/542_useradd-O_option
       + debian/patches/401_cppw_src.dpatch
       + debian/patches/428_grpck_add_prune_option
     - Updated translations:
       + Basque. Closes: #473555
       + German. Closes: #473646
       + Italian. Closes: #472951
       + Korean. Closes: #471935
       + Portuguese. Closes: #472244
       + Russian. Closes: #472506
       + Slovak. Closes: #471802
       + Turkish. Closes: #473279
   * debian/watch: Add a watch file for shadow.
   * debian/rules, debian/recode_manpages.sh: Do not recode the manpages.
     Keep them in UTF-8.
   * debian/rules, debian/control: login (>= 970502-1) was already provided
     by login in Hamm. libpam-modules (>= 0.72-5) was already provided by
     libpam-modules in Potato. libpam-runtime (>= 0.76-14) was already provided
     by libpam-runtime in Sarge (now oldstable). Simplify the dependencies.
   * debian/control: Move the dependency on libpam-modules from Depends to
     Pre-Depends. The login package is Essential, and without libpam-modules,
     login or su are not functional. Thanks to Steve Langasek for pointing this
   * debian/control: There's no need for a dependency on login (now that it is
     unversionned; see above) in the passwd package.
   * debian/control: The passwd's Replaces on manpages-de can be versionned
     again. The su(1) manpage was removed from manpages-de.
   * debian/securetty.linux: Added ttyUSB0, ttyUSB1, ttyUSB2, and MPC5200
     serial ports (ttyPSC0, ttyPSC1, ttyPSC2, ttyPSC3, ttyPSC4, ttyPSC5).
     Closes: #461374
   * debian/control: Change XS-X-Vcs-Svn to Vcs-Svn.  Update the link to the
     new repository layout.  Add a Vcs-Browser field.
   * debian/control: Added Homepage field.
   * debian/passwd.postrm: Removed (was empty).
 2edb489bd07a9a09e378cc3a53da7315 1160 admin required shadow_4.1.1-1.dsc
 ae893c18fdb0a89bc7991ba1098f1446 2720267 admin required shadow_4.1.1.orig.tar.gz
 f6b6241d60ae93cf59d5c7076c863c75 76018 admin required shadow_4.1.1-1.diff.gz
 d396813553676b7114aef714d961ab2d 851106 admin required passwd_4.1.1-1_i386.deb
 057b56c6f418289d873fc7aceceeb3a5 857970 admin required login_4.1.1-1_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)


  to pool/main/s/shadow/login_4.1.1-1_i386.deb
  to pool/main/s/shadow/passwd_4.1.1-1_i386.deb
  to pool/main/s/shadow/shadow_4.1.1-1.diff.gz
  to pool/main/s/shadow/shadow_4.1.1-1.dsc
  to pool/main/s/shadow/shadow_4.1.1.orig.tar.gz

Reply to: