[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted pgapack 1.1-1 (source i386)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 15 Mar 2008 13:49:45 -0500
Source: pgapack
Binary: pgapack libpgapack-serial1 libpgapack-mpi1
Architecture: source i386
Version: 1.1-1
Distribution: unstable
Urgency: low
Maintainer: Dirk Eddelbuettel <edd@debian.org>
Changed-By: Dirk Eddelbuettel <edd@debian.org>
Description: 
 libpgapack-mpi1 - A general-purpose genetic algorithm package
 libpgapack-serial1 - A general-purpose genetic algorithm package
 pgapack    - A general-purpose genetic algorithm package
Closes: 60376 134331 333381 359549 379168 379168 379388 404027
Changes: 
 pgapack (1.1-1) unstable; urgency=low
 .
   * Really good news: The MCS divsion of Argonne National Laboratories has
     agreed to relicense pgapack using the MPICH2 license. So pgapack is
     now Free Software and can move into Debian's main archive!
     Our thanks go to David Levine and Rusty Lusk to make this possible.
 .
   * debian/copyright: Updated using MPICH2 license now chosen upstream
 .
   * New maintainer, following Andreas' offer dated 2006-10-04 in #379388
 .
   * debian/control: Change section to math		(Closes: #379388)
 .
   * Added new brinary packages libpgapack-mpi1 and libpgapack-serial1
   * The MPI package is configured using Open MPI where available and LAM
     where not.
   * debian/control: Changed Build-Depends: to use OpenMPI where available,
     and LAM otherwise.
 .
   * Finally acknowledges old NMUs 		(Closes: #379168,#359549)
 .
   * source/integer.c: Apply patch for one-off error 	(Closes: #333381)
 .
   * source/report.c:  Do not unconditionally print at generation 1
 .
   * debian/rules: Remove a bashism 			(Closes: #379168)
   * debian/rules: Install examples directly 		(Closes: #134331)
   * debian/control: libpgapack-lam1 Depends on lam4 	(Closes: #60376)
   * debian/rules: Rewritten using debhelper
   * debian/control: Added Build-Depends: section for debhelper
 .
   * No longer install mpi.h in /usr/include		(Closes: #404027)
 .
   * debian/control: Updated Standards-Version: to current version
 .
   * man/man1/PGAGetCharacterAllele.1: fix whatis entry 		(lintian)
Files: 
 7e499be82d6163ef35a65b1c612d8f15 712 math optional pgapack_1.1-1.dsc
 207e5d7ea555bf8d039b205ae4d10387 324907 math optional pgapack_1.1.orig.tar.gz
 2f38acdd98fbe0349df56e0a96fee38b 8752 math optional pgapack_1.1-1.diff.gz
 deee69883c77a8350409c615e4964daf 137732 math optional pgapack_1.1-1_i386.deb
 f1e20c0f7370855997567a2017348169 135444 math optional libpgapack-serial1_1.1-1_i386.deb
 6b8d9fb95af734b6b715fdd4d2b3931a 113530 math optional libpgapack-mpi1_1.1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFH3B7XCZSR95Gw07cRAgB+AJ4zYQprvxWcsIkFwDSHfCc1Cleu3QCdFRFs
6YAghCUW13CPkRxtIqleq0E=
=nUX/
-----END PGP SIGNATURE-----


Accepted:
libpgapack-mpi1_1.1-1_i386.deb
  to pool/main/p/pgapack/libpgapack-mpi1_1.1-1_i386.deb
libpgapack-serial1_1.1-1_i386.deb
  to pool/main/p/pgapack/libpgapack-serial1_1.1-1_i386.deb
pgapack_1.1-1.diff.gz
  to pool/main/p/pgapack/pgapack_1.1-1.diff.gz
pgapack_1.1-1.dsc
  to pool/main/p/pgapack/pgapack_1.1-1.dsc
pgapack_1.1-1_i386.deb
  to pool/main/p/pgapack/pgapack_1.1-1_i386.deb
pgapack_1.1.orig.tar.gz
  to pool/main/p/pgapack/pgapack_1.1.orig.tar.gz


Reply to: