[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted tleds 1.05beta10-9 (source i386)

Hash: SHA1

Format: 1.7
Date: Sat, 27 Aug 2005 12:38:15 -0700
Source: tleds
Binary: tleds
Architecture: source i386
Version: 1.05beta10-9
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Russ Allbery <rra@stanford.edu>
 tleds      - blinks keyboard LEDs for TX and RX network packets
Closes: 32074 60653 103920 159383 271240 276789
 tleds (1.05beta10-9) unstable; urgency=low
   * QA upload.
   * This package is orphaned.  Change maintainer to QA team.
   * Security: Do not create symlinks in /tmp as root, do not trust PIDs in
     /tmp/tleds.pid when running as root, and create the PID file securely
     when running as a regular user.  Thanks to Juergen Salk for the patch.
     (Closes: #276789)
   * Security: Check the ownership of the PID file and refuse to signal the
     process unless the PID file is owned by the user running tleds -k.
   * Add a -n option to use the ScrollLock light for both incoming and
     outgoing traffic, since using NumLock does nasty things to some
     keyboards.  Thanks, Maxime Chatelle.  (Closes: #32074)
   * Use daemon to background rather than a simple fork and detach from a
     controlling terminal if run as root.  This will hopefully prevent
     tleds from grabbing a remote login terminal and preventing a clean
     exit from the terminal that started it.  (Closes: #271240)
   * Renice to a priority of 10 in the init script.  Blinking the keyboard
     LEDs isn't that important.  (Closes: #60653)
   * Rip out all remnants of Linux 2.0 support.  This means the binary
     is called tleds as documented.  (Closes: #159383)
   * Install the binary into bin instead of sbin; tleds supposedly
     supports running as a normal user if the init script is disabled.
   * Remove any mention of xtleds from the man page, since the Debian
     package has never installed it.  (Closes: #103920)
   * Remove the unnecessary sleep 1 in the init script.
   * Add a README.Debian file explaining how to get started with the
     package and noting differences between the Debian package and
   * Update standards version to 3.6.2.
     - Build with debugging by default and support noopt.
     - Don't always strip the binaries; let debhelper handle that.
   * Update to debhelper compatibility level V4.
   * Rephrase the description to be more accurate and succinct.
   * Reformatted the copyright file, added the upstream author, added the
     actual copyright statement, and copied the GPL notice from the source.
   * Change section to utils to match override.
 546111602a0459eb68554bc62bef0e0e 571 utils extra tleds_1.05beta10-9.dsc
 81f85a7633d359f7f02e76df188f66a2 16596 utils extra tleds_1.05beta10-9.diff.gz
 4b5296b03d329fd674efd33a23a97454 16534 utils extra tleds_1.05beta10-9_i386.deb
Version: GnuPG v1.4.1 (GNU/Linux)


  to pool/main/t/tleds/tleds_1.05beta10-9.diff.gz
  to pool/main/t/tleds/tleds_1.05beta10-9.dsc
  to pool/main/t/tleds/tleds_1.05beta10-9_i386.deb

Reply to: