[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted lintian 1.23.4 (all source)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon,  6 Dec 2004 01:41:21 +0100
Source: lintian
Binary: lintian
Architecture: source all
Version: 1.23.4
Distribution: unstable
Urgency: low
Maintainer: Debian Lintian Maintainers <lintian-maint@debian.org>
Changed-By: Frank Lichtenheld <djpig@debian.org>
Description: 
 lintian    - Debian package checker
Closes: 242345 257904 258815 261890 276504 276945 277393 278513 280080 282030
Changes: 
 lintian (1.23.4) unstable; urgency=low
 .
   The "A little pause from the sarge release work" release.
 .
   * checks/changelog-file:
     + [FL] file has apparently changed its output format for
       symlinks sometime in the past. This broke symlink detection.
       (Closes: #276504)
   * checks/deb-format, unpack/unpack-binpkg-l1, unpack/unpack-binpkg-l2:
     + [CW] Fix binary package data member extraction to work with arbitrary
       compression algorithms instead of hardcoding data.tar.gz.
   * checks/debconf{,.desc}:
     + [FL] The SETTITLE command was introduced in debconf version
       1.3.22. Check the depends for that (Closes: #261890)
     + [FL] Warn about incorrect usage of commas in translated Choices
       fields. Patch by Denis Barbier after a suggestion by Andreas
       Metzler (Closes: #282030)
   * checks/debhelper:
     + [FL] Update list of debhelper scripts that modify maintainer
       scripts
   * checks/menu-format.desc:
     + [FL] Adjust references to the menu documentation. Noted by
       Jack Moffitt (Closes: #277393)
   * checks/po-debconf{,.desc}:
     + [FL] Check for outdated .pot files when using po-debconf.
       This requires a new dependency on intltool-debian. Patch
       by Denis Barbier with corrections by JvW (Closes: #242345)
   * checks/scripts{,.desc}:
     + [FL] Fix copy-and-paste error in description
       of wrong-path-for-gnuplot (Closes: #276945)
       Thanks to Lionel Elie Mamane for reporting.
     + [FL] Add tclsh8.3 to list of valid interpreters as it is used
       in at least one package. (Closes: #280080)
     + [FL] Issue wrong-path-for-{ruby,python} even if the path contained
       a version number. Change the description of the tag to reflect that.
       (Closes: #257904)
 .
   * frontend/lintian-info:
     + [FL] Overrides start with O:, not with 0:, d'oh!
       (Closes: #258815)
 .
   * lib/Tags.pm:
     + [FL] Add missing "use Util;", noted by Robert Luberda
       (Closes: #278513)
 .
   * testset/debconf/*,testset/tags.debconf:
     + [FL] New test package for debconf and udeb tests
   * testset/diffs:
     + [JvW] Remove the shipped ELF binary, can be compiled at test-time
   * testset/runtests:
     + [FL] Make checks of udeb packages possible
Files: 
 58413a8540cbdec3f0c6d1bdf5501541 738 devel optional lintian_1.23.4.dsc
 f6b09204ca78fe503ce4ee588b8b908e 253336 devel optional lintian_1.23.4.tar.gz
 a40e0a1afa3cf21ba24bd512e6b0de63 219554 devel optional lintian_1.23.4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBukoyQbn06FtxPfARAgd6AJ9TRss/obp20vvmojZGSuahV9DOaACfbdJ4
B6zRrHlHrYfqox7AkjpEyJM=
=Zp4f
-----END PGP SIGNATURE-----


Accepted:
lintian_1.23.4.dsc
  to pool/main/l/lintian/lintian_1.23.4.dsc
lintian_1.23.4.tar.gz
  to pool/main/l/lintian/lintian_1.23.4.tar.gz
lintian_1.23.4_all.deb
  to pool/main/l/lintian/lintian_1.23.4_all.deb



Reply to: