[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted glibc 2.3.1-1 (i386 source all)

Hash: SHA1

Format: 1.7
Date: Thu, 17 Oct 2002 08:37:52 -0400
Source: glibc
Binary: libc6.1-prof libc1 libc0.3-pic locales glibc-doc libc6-pic libc1-prof libc0.3 libc0.3-dbg libc6.1-dev libc1-pic libc6-prof libc1-dbg libc6-dev-sparc64 libc6 libc0.3-dev libc6-dbg nscd libc6.1-dbg libc6.1-pic libc6-sparc64 libc6-dev libc0.3-prof libc6.1 libc1-dev
Architecture: source i386 all
Version: 2.3.1-1
Distribution: unstable
Urgency: low
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Changed-By: Jeff Bailey <jbailey@nisa.net>
 glibc-doc  - GNU C Library: Documentation
 libc6      - GNU C Library: Shared libraries and Timezone data
 libc6-dbg  - GNU C Library: Libraries with debugging symbols
 libc6-dev  - GNU C Library: Development Libraries and Header Files.
 libc6-pic  - GNU C Library: PIC archive library
 libc6-prof - GNU C Library: Profiling Libraries.
 locales    - GNU C Library: National Language (locale) data [support]
 nscd       - GNU C Library: Name Service Cache Daemon
Closes: 155606 155904 156821 157374 159417 160846
 glibc (2.3.1-1) unstable; urgency=low
   * This is the "twilight" release...
   * Jeff Bailey <jbailey@nisa.net>
     - Upgrade tarballs to 2.3.1
     - version: Update to 2.3.1
     - debian/sysdeps/linux.mk: Do not build optimized libraries
     - debian/rules.d/control.mk: Likewise
     - debian/control.in/main: Require binutils for ppc
     - debian/patches/elf-machine-rela-mips.dpatch: New file
     - debian/patches/0list: Update accordingly.
     - debian/rules: Use -O on i386.  This should go somewhere else,
     but I want to get this release out.
   * XXX Below here was during the 2.3 development, and never released.
   * Jeff Bailey <jbailey@nisa.net>
     - Upgrade tarballs to 2.3
     - version: Update to 2.3
     - debian/patches/hppa-data-start.dpatch: Remove, incorporated upstream
     - debian/patches/various-lsb-fixes.dpatch: Remove, incorporated upstream
     - debian/patches/0list: adjust accordingly
                             Also, prune ia64-reloc-none from the list.
 			    I can't tell from the code snippet if this
 			    has been incorporated or not.
     - .cvsignore: Add the stamp directories
     - debian/rules: Don't put CFLAGS in configparms, resolves ldconfig
       miscompile on i386
     - debian/rules: Add freebsd-i386 support
     - debian/rules.d/control.mk: Add freebsd-i386 support
     - debian/sysdeps/freebsd.mk: New file to add freebsd-i386 support
     - debian/sysdeps/paths.mk: Add freebsd-i386 support
     - debian/sysdeps/soname.mk: Add freebsd-i386 support
   * XXX Below here was during the 2.2.94 development, and never released.
   * Jeff Bailey <jbailey@nisa.net>
     - Upgrade tarballs to 2.2.94
     - version: Update to 2.2.94
     - debian/patches/cvs: Remove
     - debian/patches/manual-texinfo4: Remove, incorporated upstream.
     - debian/patches/i386-mathinline.dpatch: Remove, glibc headers require
       ANSI compilers.
     - debian/patches/db1-addon-enabler.dpatch: Remove
     - debian/patches/0list: adjust accordingly
     - debian/patches/0list: Comment out string2-pointer-arith.
       This was originally created to fix #44697, but without this
       patch, 44697 is no longer reproducable.
     - debian/patches/fhs-linux-paths.dpatch: Update to new template format
     - .cvsignore: New file
   * XXX Below here was during the 2.2.93 development, and never released.
   * Jeff Bailey <jbailey@nisa.net>
      - Upgrade tarballs to 2.2.93
      - version: Update to 2.2.93
      The following important patches are still disabled:
        glibc22-hppa-pthreads, glibc22-hppa-rela, ia64-perf
      - debian/patches/0list: prune commented out patches that won't
        be needed anymore
      - debian/patches/ia64-reloc-none.dpatch: Updated, thank to
        Randolph Chung <randolph@tausq.org>
      - debian/make-cvs-patch.sh: New file.
      - debian/patches/template.dpatch: Update headers to new format.
      - debian/patches/hurd-ioperms.dpatch - Deleted
      - debian/patches/hurd-lfs64.dpatch - Deleted
      - debian/patches/hurd-update.dpatch - Deleted
      - debian/patches/syserrlist.dpatch - Deleted
      - debian/README - More updates
      - debian/rules.d/control.mk: debian/control should Depend on
      - debian/sysdeps/depflags.pl: Actually add the dependancy on
        libdb1-compat.  This is an update to GOTO Masanori's change,
        Thanks to Ryan Murray for catching this.
      - debian/patches/mathpatch.dpatch: Prune
      - debian/rules.d/patch.mk: Add `setup' as an alias for `patch'
        to provide dbs compatability.
      - debian/patches/cvs.dpatch: Sync with CVS from September 14th.
      - debian/patches/0list: Updated
   * GOTO Masanori <gotom@debian.or.jp>
      - debian/packages.d/glibc-doc.mk: change texi2html processed file from
        chapters.texi to libc.texinfo. Closes: #159417
      - debian/packages.d/libc-{dbg,pic,prof}.mk: fix /usr/doc removal
        compilation failure.
      - debian/libc/DEBIAN/postinst: Fix 'grep -v' failure if the size of
        /etc/ld.so.nohwcap is 0.
      - debian/rules.d/control.mk: Generate libc-opt control information.
      - Updating 2.2.9x fixes LSB 1.2 compliance. Closes: #156821
      - debian/control: add Depends: libdb1-compat.
        Until woody, libdb1 is included in libc6 package. However after sarge,
        libdb1 support is removed. libdb1-compat contains libdb1 which is
        formerly provided by libc6. Now libc6 depends on libdb1-compat,
        so upgrading from woody to sarge does not break any libdb1 issues.
        Closes: #155904
      - debian/patches/glibc22-hppa-fcntl.dpatch: added, patched by
        Carlos O'Donell <carlos@baldric.uwo.ca>.
      - debian/patches/glibc22-hppa-fcntl-lfs.dpatch: added, patched by
        Randolph Chung <tausq@debian.org>. Closes: #160846
   * Ben Collins <bcollins@debian.org>
     - Make sparc64 build use gcc-3.2.
     - Update all config options to not use --disable-sanity-checks, since we
       are actually using gcc-3.2 for everything.
     - Patch cleanups.
     - Re-enable optimized libs. Includes a simple mechanism which should fix
       the conflicting symbols during libc/libc-opt upgrade scenarios. This
       means that libc6-v9, libc6-i586 and libc6-i686 are back in full swing.
     - Remove all references to /usr/doc symlink crap, which is deprecated.
   * XXX Below here was during the 2.2.92 development, and never released.
   * Jeff Bailey <jbailey@nisa.net>
      - Upgrade tarballs to 2.2.92
      - version: Update to 2.2.92
      - debian/control.in/main: Require gcc-3.2 for all archs
      - debian/patches/0list: prune glibc-cvs, glibc22-s390-resource,
        gmon-start, locales-de_CH, sh-sysdep, alpha-build-failure
        These are already included in the 2.3 series.
      - debian/patches/glibc22-misc.dpatch: Split into ...
        debian/patches/makeconfig.dpatch: ... this
        debian/patches/locale-es_AR.dpatch: ... and this
        debian/patches/i386-mathinline.dpatch: ... and this
        debian/patches/ldconfig.dpatch: ... and this.
      - debian/patches/makeconfig.dpatch: Update for 2.3 series
      - debian/patches/0list: Temporarily disable some other patches:
        glibc22-hppa-pthreads, glibc22-hppa-rela, ia64-perf
      - debian/rules: memset.S works on ppc now, so stop deleting it.  Thanks
        to Jack Howarth <howarth@fuse.net> for letting us know.
      - debian/sysdeps/gnu.mk: Remove --enable-libio, now set by default.  Add
        NO_TEST = yes, make check does not run on i386-gnu.
      - debian/sysdeps/tools.mk: Hardcode gcc-3.2 for $(CC) and $(BUILD_CC)
        until gcc-defaults switches.
      - debian/rules: use CC=$(CC) when calling configure to get any changed
      - debian/control.in/main: Require binutils (>=
      - debian/rules: Add time/date stamps to beginning and end of log files
      - db1-addon-2.1.3.tar.bz2: Delete
      - debian/ppc-memset.S: Delete
      - debian/README: Update
   * GOTO Masanori <gotom@debian.or.jp>
      - debian/packages.d/libc-dbg.mk: update libpthread-0.9 -> 0.10.
      - packages.d/libc.mk: likewise.
      - packages.d/optimized.mk: likewise.
      - packages.d/sparc64.mk: likewise.
      - debian/patches/glibc22-hppa-mcontext.dpatch: Fix unmatched userland
        mcontext_t definition differed from kernel. Patched by
        Carlos O'Donell <carlos@baldric.uwo.ca>. Closes: #157374
   * XXX Below here was during the 2.2.5 development, and never released.
   * GOTO Masanori <gotom@debian.or.jp>
     - debian/patches/glibc-cvs.dpatch: Update from Glibc CVS.
     - debian/patches: Dropped applying below patches due to updating
         hurd-update, hurd-ioperms, ia64-strncpy, sparc-misc, resolv-nss_dns,
         glibc-openoffice-fixes, xdr-array-security, hurd-lfs64,
         syserrlist, mathpatch
     - Fix gcc 3.1/3.2 compatibility building for glibc on ppc, with upstream
       patched by Jack Howarth <howarth@bromo.msbb.uc.edu> and
       Franz Sirl <Franz.Sirl-kernel@lauterbach.com>.
       Closes: #155606
 d80e03a24af6c9d097f29c223e09960e 1369 libs required glibc_2.3.1-1.dsc
 37bcd63e087a81255da9d481587bad13 13090602 libs required glibc_2.3.1-1.tar.gz
 a2a9a66f30c12c3bef286fb0b7e9bf80 3180600 base required libc6_2.3.1-1_i386.deb
 dfebb37ef482678a1ca706d946928187 2385922 devel standard libc6-dev_2.3.1-1_i386.deb
 642a442c5f78244b561efaa4ea8112e0 890174 devel extra libc6-prof_2.3.1-1_i386.deb
 22351c20c64e14aa5a32f8960eab48b4 860098 devel extra libc6-dbg_2.3.1-1_i386.deb
 57fa2ef7d1b2f45e24e4c91fae2cecc2 821588 devel optional libc6-pic_2.3.1-1_i386.deb
 e36900fcae8f4b0c05bf41f934c8ebbe 61364 admin optional nscd_2.3.1-1_i386.deb
 e8b4f84aab9fda4ff25e323441f7bf04 3684254 base standard locales_2.3.1-1_all.deb
 f0dcb2e53946f375d32e9a583e8c2da9 2953208 doc optional glibc-doc_2.3.1-1_all.deb

Version: GnuPG v1.0.7 (GNU/Linux)


  to pool/main/g/glibc/glibc-doc_2.3.1-1_all.deb
  to pool/main/g/glibc/glibc_2.3.1-1.dsc
  to pool/main/g/glibc/glibc_2.3.1-1.tar.gz
  to pool/main/g/glibc/libc6-dbg_2.3.1-1_i386.deb
  to pool/main/g/glibc/libc6-dev_2.3.1-1_i386.deb
  to pool/main/g/glibc/libc6-pic_2.3.1-1_i386.deb
  to pool/main/g/glibc/libc6-prof_2.3.1-1_i386.deb
  to pool/main/g/glibc/libc6_2.3.1-1_i386.deb
  to pool/main/g/glibc/locales_2.3.1-1_all.deb
  to pool/main/g/glibc/nscd_2.3.1-1_i386.deb

Reply to: